summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4181e5c01435
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gkleds
+ pkgdesc = Gkrellm plugin to monitor the CapsLock, NumLock, and ScrollLock keys
+ pkgver = 0.8.2
+ pkgrel = 2
+ url = http://freshmeat.net/projects/gkleds/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gkrellm
+ depends = gtk2
+ source = http://heim.ifi.uio.no/~oyvinha/files/files/gkleds-0.8.2.tar.gz
+ md5sums = 140719ffcba3ff84b9b9c7c57b24fbff
+
+pkgname = gkleds
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b947579f2fa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ota <otakar.trunecek@gmail.com>
+# Contributor: eric <eric@archlinux.org>
+# Contributor: orelien <aurelien.foret@wanadoo.fr>
+
+pkgname=gkleds
+pkgver=0.8.2
+pkgrel=2
+pkgdesc="Gkrellm plugin to monitor the CapsLock, NumLock, and ScrollLock keys"
+arch=(i686 x86_64)
+source=("http://heim.ifi.uio.no/~oyvinha/files/files/$pkgname-$pkgver.tar.gz")
+depends=('gkrellm' 'gtk2')
+license=('GPL')
+url="http://freshmeat.net/projects/gkleds/"
+#url="http://heim.ifi.uio.no/~oyvinha/article.php?2.0.0"
+md5sums=('140719ffcba3ff84b9b9c7c57b24fbff')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure
+ make
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Ds src/.libs/gkleds.so "$pkgdir/usr/lib/gkrellm2/plugins/gkleds.so"
+}