summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD15
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..826d88cd5340
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = glasscalc
+ pkgdesc = A small script that calculates IVSHMEM device size for Looking Glass
+ pkgver = 1
+ pkgrel = 1
+ url = https://gist.github.com/NeoTheFox/c867fbfcaea74749e96f3006b12675fb
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = WTFPL
+ depends = bash
+ depends = bc
+ source = glasscalc.sh::https://gist.githubusercontent.com/NeoTheFox/c867fbfcaea74749e96f3006b12675fb/raw/d9447400c99edb71b6d654df6b07eda3dbb042ca/glasscalc.sh
+ md5sums = SKIP
+
+pkgname = glasscalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1da7eccc0d23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+pkgname=glasscalc
+pkgver=1
+pkgrel=1
+pkgdesc="A small script that calculates IVSHMEM device size for Looking Glass"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://gist.github.com/NeoTheFox/c867fbfcaea74749e96f3006b12675fb"
+license=('WTFPL')
+depends=('bash' 'bc')
+source=(glasscalc.sh::'https://gist.githubusercontent.com/NeoTheFox/c867fbfcaea74749e96f3006b12675fb/raw/d9447400c99edb71b6d654df6b07eda3dbb042ca/glasscalc.sh')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+package() {
+ install -Dm755 "glasscalc.sh" "$pkgdir/usr/bin/glasscalc.sh"
+}