summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a93414a4c7b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = glfw2to3-git
+ pkgdesc = Porting library to make GLFW 2.x games run on top of GLFW 3.x
+ pkgver = 2.7.10
+ pkgrel = 1
+ url = https://www.glfw.org/
+ arch = x86_64
+ license = ZLIB
+ makedepends = git
+ makedepends = meson
+ depends = glfw
+ provides = glfw2to3
+ provides = glfw2
+ conflicts = glfw2to3
+ conflicts = glfw2
+ source = git+https://github.com/linkmauve/glfw2to3
+ sha256sums = SKIP
+
+pkgname = glfw2to3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd19442bcb13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgname=glfw2to3-git
+pkgver=2.7.10
+pkgrel=1
+pkgdesc="Porting library to make GLFW 2.x games run on top of GLFW 3.x"
+arch=('x86_64')
+url="https://www.glfw.org/"
+license=('ZLIB')
+depends=('glfw')
+makedepends=('git' 'meson')
+provides=('glfw2to3' 'glfw2=2.7.10')
+conflicts=('glfw2to3' 'glfw2')
+source=("git+https://github.com/linkmauve/glfw2to3")
+sha256sums=('SKIP')
+
+prepare() {
+ cd glfw2to3
+}
+
+build() {
+ cd glfw2to3
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd glfw2to3
+ DESTDIR="$pkgdir"/ ninja -C build install
+
+ # This would conflict with glfw3.
+ rm "$pkgdir"/usr/lib/libglfw.so
+}