summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--glib.install20
3 files changed, 10 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71898d87123b..a00fdb5fecff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = glib
pkgdesc = Common C routines used by Gtk+ and other libs
pkgver = 1.2.10
- pkgrel = 13
+ pkgrel = 18
url = http://www.gtk.org/
- install = glib.install
arch = i686
arch = x86_64
+ arch = armv6h
license = LGPL
depends = glibc
depends = sh
options = !makeflags
- source = ftp://ftp.gnome.org/pub/gnome/sources/glib/1.2/glib-1.2.10.tar.gz
+ source = https://download.gnome.org/sources/glib/1.2/glib-1.2.10.tar.gz
source = gcc340.patch
source = aclocal-fixes.patch
source = glib1-autotools.patch
diff --git a/PKGBUILD b/PKGBUILD
index 9ef614b8fbc9..c1bc68795502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
pkgname=glib
pkgver=1.2.10
-pkgrel=13
+pkgrel=18
pkgdesc="Common C routines used by Gtk+ and other libs"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h')
url="http://www.gtk.org/"
license=('LGPL')
depends=('glibc' 'sh')
options=('!makeflags')
-install=glib.install
-source=(ftp://ftp.gnome.org/pub/gnome/sources/glib/1.2/${pkgname}-${pkgver}.tar.gz
+source=(https://download.gnome.org/sources/glib/1.2/${pkgname}-${pkgver}.tar.gz
gcc340.patch aclocal-fixes.patch glib1-autotools.patch)
sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'
'a2cc224a66aeffdcac16ebd9e8af18143cf54918'
@@ -24,6 +23,7 @@ prepare() {
patch -Np0 -i "${srcdir}/aclocal-fixes.patch"
patch -Np1 -i "${srcdir}/glib1-autotools.patch"
sed -i -e 's/ifdef[[:space:]]*__OPTIMIZE__/if 0/' glib.h
+ rm acinclude.m4
}
build() {
@@ -32,10 +32,12 @@ build() {
CONFIGFLAG='--host=i686-pc-linux-gnu --target=i686-pc-linux-gnu'
elif [[ $CARCH = "x86_64" ]]; then
CONFIGFLAG='--host=x86_64-unknown-linux-gnu --target=x86_64-unknown-linux-gnu'
+ elif [[ $CARCH = "armv6h" ]]; then
+ CONFIGFLAG='--host=armv6l-unknown-linux-gnueabihf --target=armv6l-unknown-linux-gnueabihf'
fi
autoreconf --force --install
- ./configure --prefix=/usr --mandir=/usr/share/man \
+ CFLAGS="-Wno-format-security" ./configure --prefix=/usr --mandir=/usr/share/man \
--infodir=/usr/share/info $CONFIGFLAG
make
}
diff --git a/glib.install b/glib.install
deleted file mode 100644
index c0046feba0f3..000000000000
--- a/glib.install
+++ /dev/null
@@ -1,20 +0,0 @@
-infodir=usr/share/info
-filelist=(glib.info.gz)
-
-post_install() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info --delete $infodir/$file $infodir/dir 2> /dev/null
- done
-}