summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Revert-list-store-Fix-a-parameter-check.patch74
-rw-r--r--PKGBUILD9
3 files changed, 7 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb21cc9880cd..e5ae84c6b10f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = glib2-patched-thumbnailer
pkgdesc = GLib2 patched with ahodesuka's thumbnailer patch.
- pkgver = 2.46.0
- pkgrel = 2
+ pkgver = 2.46.1
+ pkgrel = 1
url = http://gist.github.com/ahodesuka/49c1d0eea4b64f24c4c7
arch = i686
arch = x86_64
@@ -22,12 +22,10 @@ pkgbase = glib2-patched-thumbnailer
conflicts = glib2
options = !docs
options = !emptydirs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.46/glib-2.46.0.tar.xz
- source = 0001-Revert-list-store-Fix-a-parameter-check.patch
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.46/glib-2.46.1.tar.xz
source = revert-warn-glib-compile-schemas.patch
source = https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/d0edf118e1c27700300038c1d82b3ff775c0216b/glib-thumbnailer.patch
- sha256sums = b1cee83469ae7d80f17c267c37f090414e93960bd62d2b254a5a96fbc5baacb4
- sha256sums = 261ae2d2c7b94460f33ab569540313e21c9a50af38a7ebe8412e49f5b309af35
+ sha256sums = 5a1f03b952ebc3a7e9f612b8724f70898183e31503db329b4f15d07163c8fdfb
sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
sha256sums = 1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d
diff --git a/0001-Revert-list-store-Fix-a-parameter-check.patch b/0001-Revert-list-store-Fix-a-parameter-check.patch
deleted file mode 100644
index 397ff93df0a8..000000000000
--- a/0001-Revert-list-store-Fix-a-parameter-check.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 19a560f9491c4964e7093e22cb3876fc53a442e6 Mon Sep 17 00:00:00 2001
-From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
-Date: Wed, 23 Sep 2015 23:16:04 +0200
-Subject: [PATCH] Revert "list store: Fix a parameter check"
-
-This reverts commit d28639507db2029b8f184a5d93e9d8c28acc1955.
-
-Bogus commit changing the behavior of g_sequence_search in violation
-of the documentation. Breaks GStreamer test suite.
----
- glib/gsequence.c | 18 +++++++-----------
- 1 file changed, 7 insertions(+), 11 deletions(-)
-
-diff --git a/glib/gsequence.c b/glib/gsequence.c
-index 75c1f76..76e24e7 100644
---- a/glib/gsequence.c
-+++ b/glib/gsequence.c
-@@ -139,8 +139,7 @@ static GSequenceNode *node_find_closest (GSequenceNode *haystack,
- GSequenceNode *needle,
- GSequenceNode *end,
- GSequenceIterCompareFunc cmp,
-- gpointer user_data,
-- gboolean return_match);
-+ gpointer user_data);
- static gint node_get_length (GSequenceNode *node);
- static void node_free (GSequenceNode *node,
- GSequence *seq);
-@@ -1080,7 +1079,7 @@ g_sequence_search_iter (GSequence *seq,
- dummy = g_sequence_append (tmp_seq, data);
-
- node = node_find_closest (seq->end_node, dummy,
-- seq->end_node, iter_cmp, cmp_data, TRUE);
-+ seq->end_node, iter_cmp, cmp_data);
-
- g_sequence_free (tmp_seq);
-
-@@ -1734,8 +1733,7 @@ node_find_closest (GSequenceNode *haystack,
- GSequenceNode *needle,
- GSequenceNode *end,
- GSequenceIterCompareFunc iter_cmp,
-- gpointer cmp_data,
-- gboolean return_match)
-+ gpointer cmp_data)
- {
- GSequenceNode *best;
- gint c;
-@@ -1765,12 +1763,10 @@ node_find_closest (GSequenceNode *haystack,
- }
- while (haystack != NULL);
-
-- /* If the best node is smaller than the data, then move one step
-- * to the right to make sure the best one is strictly bigger than the data.
-- * We do return the last exact match or the node after it, depending on
-- * the return_match argument.
-+ /* If the best node is smaller or equal to the data, then move one step
-+ * to the right to make sure the best one is strictly bigger than the data
- */
-- if (best != end && (c < 0 || (c == 0 && !return_match)))
-+ if (best != end && c <= 0)
- best = node_get_next (best);
-
- return best;
-@@ -1992,7 +1988,7 @@ node_insert_sorted (GSequenceNode *node,
- {
- GSequenceNode *closest;
-
-- closest = node_find_closest (node, new, end, iter_cmp, cmp_data, FALSE);
-+ closest = node_find_closest (node, new, end, iter_cmp, cmp_data);
-
- node_unlink (new);
-
---
-2.5.3
-
diff --git a/PKGBUILD b/PKGBUILD
index be6c18968e4a..9a2bc133edc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgbase=glib2-patched-thumbnailer
pkgname=glib2-patched-thumbnailer
-pkgver=2.46.0
+pkgver=2.46.1
_patchver=d0edf118e1c27700300038c1d82b3ff775c0216b
-pkgrel=2
+pkgrel=1
pkgdesc="GLib2 patched with ahodesuka's thumbnailer patch."
url="http://gist.github.com/ahodesuka/49c1d0eea4b64f24c4c7"
arch=(i686 x86_64)
@@ -18,17 +18,14 @@ optdepends=('python2: for gdbus-codegen and gtester-report'
options=('!docs' '!emptydirs')
license=('LGPL')
source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver:0:4}/glib-$pkgver.tar.xz
- 0001-Revert-list-store-Fix-a-parameter-check.patch
revert-warn-glib-compile-schemas.patch
https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/$_patchver/glib-thumbnailer.patch)
-sha256sums=('b1cee83469ae7d80f17c267c37f090414e93960bd62d2b254a5a96fbc5baacb4'
- '261ae2d2c7b94460f33ab569540313e21c9a50af38a7ebe8412e49f5b309af35'
+sha256sums=('5a1f03b952ebc3a7e9f612b8724f70898183e31503db329b4f15d07163c8fdfb'
'049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97'
'1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d')
prepare() {
cd glib-$pkgver
- patch -Np1 -i ../0001-Revert-list-store-Fix-a-parameter-check.patch
patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
patch -Np1 -i ${srcdir}/glib-thumbnailer.patch
}