summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--gio-querymodules.hook11
-rw-r--r--glib-compile-schemes.hook12
4 files changed, 38 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b253dfd2e28..1f95d02c46bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 16 06:39:09 UTC 2016
+# Sun May 8 09:30:19 UTC 2016
pkgbase = glib2-patched-thumbnailer
pkgdesc = GLib2 patched with ahodesuka's thumbnailer patch.
pkgver = 2.48.0
- pkgrel = 1
+ pkgrel = 2
url = http://gist.github.com/ahodesuka/49c1d0eea4b64f24c4c7
arch = i686
arch = x86_64
@@ -25,9 +25,13 @@ pkgbase = glib2-patched-thumbnailer
options = !docs
options = !emptydirs
source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.48/glib-2.48.0.tar.xz
+ source = glib-compile-schemes.hook
+ source = gio-querymodules.hook
source = revert-warn-glib-compile-schemas.patch
source = https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/d0edf118e1c27700300038c1d82b3ff775c0216b/glib-thumbnailer.patch
sha256sums = 744be6931ca914c68af98dc38ff6b0cf8381d65e335060faddfbf04c17147c34
+ sha256sums = e1123a5d85d2445faac33f6dae1085fdd620d83279a4e130a83fe38db52b62b3
+ sha256sums = 5ba204a2686304b1454d401a39a9d27d09dd25e4529664e3fd565be3d439f8b6
sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
sha256sums = 1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d
diff --git a/PKGBUILD b/PKGBUILD
index d5607f2b2915..6a4b3b1b05a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=glib2-patched-thumbnailer
pkgname=glib2-patched-thumbnailer
pkgver=2.48.0
_patchver=d0edf118e1c27700300038c1d82b3ff775c0216b
-pkgrel=1
+pkgrel=2
pkgdesc="GLib2 patched with ahodesuka's thumbnailer patch."
url="http://gist.github.com/ahodesuka/49c1d0eea4b64f24c4c7"
arch=(i686 x86_64)
@@ -18,9 +18,13 @@ optdepends=('python2: for gdbus-codegen and gtester-report'
options=('!docs' '!emptydirs')
license=('LGPL')
source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver:0:4}/glib-$pkgver.tar.xz
+ glib-compile-schemes.hook
+ gio-querymodules.hook
revert-warn-glib-compile-schemas.patch
https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/$_patchver/glib-thumbnailer.patch)
sha256sums=('744be6931ca914c68af98dc38ff6b0cf8381d65e335060faddfbf04c17147c34'
+ 'e1123a5d85d2445faac33f6dae1085fdd620d83279a4e130a83fe38db52b62b3'
+ '5ba204a2686304b1454d401a39a9d27d09dd25e4529664e3fd565be3d439f8b6'
'049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97'
'1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d')
@@ -54,4 +58,8 @@ package() {
# Our gdb does not ship the required python modules, so remove it
rm -rf "$pkgdir/usr/share/gdb/"
+
+ # install hooks
+ install -dm755 "$pkgdir"/usr/share/libalpm/hooks/
+ install -m644 "$srcdir"/{glib-compile-schemes,gio-querymodules}.hook "$pkgdir"/usr/share/libalpm/hooks/
}
diff --git a/gio-querymodules.hook b/gio-querymodules.hook
new file mode 100644
index 000000000000..193233398168
--- /dev/null
+++ b/gio-querymodules.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gio/modules/*.so
+
+[Action]
+Description = Updating GIO module cache...
+When = PostTransaction
+Exec = /usr/bin/gio-querymodules /usr/lib/gio/modules
diff --git a/glib-compile-schemes.hook b/glib-compile-schemes.hook
new file mode 100644
index 000000000000..04dc59b1a638
--- /dev/null
+++ b/glib-compile-schemes.hook
@@ -0,0 +1,12 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/glib-2.0/schemas/*.gschema.xml
+Target = usr/share/glib-2.0/schemas/*.gschema.override
+
+[Action]
+Description = Compiling GSettings XML schema files...
+When = PostTransaction
+Exec = /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas