summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--glib-thumbnailer.patch36
3 files changed, 25 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dd5c702389d..febd38fdc6ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = glib2-patched-thumbnailer
pkgdesc = GLib2 patched with ahodesuka's thumbnailer patch.
- pkgver = 2.74.0
+ pkgver = 2.74.1
pkgrel = 1
url = https://gist.github.com/Dudemanguy/d199759b46a79782cc1b301649dec8a5
arch = x86_64
license = LGPL
checkdepends = desktop-file-utils
+ checkdepends = glib2
makedepends = gettext
makedepends = gtk-doc
makedepends = shared-mime-info
@@ -26,7 +27,7 @@ pkgbase = glib2-patched-thumbnailer
optdepends = python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
optdepends = libelf: gresource inspection tool
optdepends = gvfs: most gio functionality
- provides = glib2=2.74.0
+ provides = glib2=2.74.1
provides = libgio-2.0.so
provides = libglib-2.0.so
provides = libgmodule-2.0.so
@@ -35,7 +36,7 @@ pkgbase = glib2-patched-thumbnailer
conflicts = glib2
options = !docs
options = staticlibs
- source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=30bd57ecf8aa051de9848ba5a2b140f4810401ff
+ source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=058491cb6f635ff6e0a57fcdd4107a40ca91c62a
source = 0001-glib-compile-schemas-Remove-noisy-deprecation-warnin.patch
source = glib-thumbnailer.patch
source = glib-compile-schemas.hook
@@ -44,7 +45,7 @@ pkgbase = glib2-patched-thumbnailer
source = gio-querymodules.script
sha256sums = SKIP
sha256sums = 6d51eb5856268d79eee01b97a299fa9f99db18b2abb4df56f2ed9e641a09138a
- sha256sums = 9f055d2a4f3fa08a7f0ca9f233a0ca6925247f572fb6873af7ac1e1f43f23d74
+ sha256sums = aac442ff2ab836e31a7adadfcaf9d7dbdd7a40eb78a4bc6df12c87739ffd3186
sha256sums = 64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25
sha256sums = 64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25
sha256sums = 2a9f9b8235f48e3b7d0f6cfcbc76cd2116c45f28692cac4bd61074c495bd5eb7
diff --git a/PKGBUILD b/PKGBUILD
index 2df565cb2457..acf054aa1f39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=glib2-patched-thumbnailer
-pkgver=2.74.0
+pkgver=2.74.1
pkgrel=1
pkgdesc="GLib2 patched with ahodesuka's thumbnailer patch."
url="https://gist.github.com/Dudemanguy/d199759b46a79782cc1b301649dec8a5"
@@ -15,13 +15,13 @@ conflicts=('glib2')
depends=(pcre2 libffi util-linux-libs zlib tumbler libsysprof-capture libmount.so libffi.so)
makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux
meson dbus)
-checkdepends=(desktop-file-utils)
+checkdepends=(desktop-file-utils glib2)
optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
'libelf: gresource inspection tool'
'gvfs: most gio functionality')
options=(!docs staticlibs)
license=(LGPL)
-_commit=30bd57ecf8aa051de9848ba5a2b140f4810401ff # tags/2.74.0^0
+_commit=058491cb6f635ff6e0a57fcdd4107a40ca91c62a # tags/2.74.1^0
source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
0001-glib-compile-schemas-Remove-noisy-deprecation-warnin.patch
glib-thumbnailer.patch
@@ -29,7 +29,7 @@ source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
glib-compile-schemas.hook gio-querymodules.{hook,script})
sha256sums=('SKIP'
'6d51eb5856268d79eee01b97a299fa9f99db18b2abb4df56f2ed9e641a09138a'
- '9f055d2a4f3fa08a7f0ca9f233a0ca6925247f572fb6873af7ac1e1f43f23d74'
+ 'aac442ff2ab836e31a7adadfcaf9d7dbdd7a40eb78a4bc6df12c87739ffd3186'
'64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25'
'64ae5597dda3cc160fc74be038dbe6267d41b525c0c35da9125fbf0de27f9b25'
'2a9f9b8235f48e3b7d0f6cfcbc76cd2116c45f28692cac4bd61074c495bd5eb7'
@@ -81,3 +81,5 @@ package() {
python -O -m compileall -d /usr/share/glib-2.0/codegen \
"$pkgdir/usr/share/glib-2.0/codegen"
}
+
+# vim:set sw=2 sts=-1 et:
diff --git a/glib-thumbnailer.patch b/glib-thumbnailer.patch
index 87ead82363e7..fcce3d7ad301 100644
--- a/glib-thumbnailer.patch
+++ b/glib-thumbnailer.patch
@@ -1,8 +1,8 @@
diff --git a/gio/glocalfileinfo.c b/gio/glocalfileinfo.c
-index 487f8cc1a..b0e6db728 100644
+index 661d2266a..74e584653 100644
--- a/gio/glocalfileinfo.c
+++ b/gio/glocalfileinfo.c
-@@ -66,6 +66,12 @@
+@@ -68,6 +68,12 @@
#include "glib-private.h"
#include "thumbnail-verify.h"
@@ -15,7 +15,7 @@ index 487f8cc1a..b0e6db728 100644
#ifdef G_OS_WIN32
#include <windows.h>
-@@ -103,6 +109,16 @@ struct ThumbMD5Context {
+@@ -105,6 +111,16 @@ struct ThumbMD5Context {
unsigned char in[64];
};
@@ -32,7 +32,7 @@ index 487f8cc1a..b0e6db728 100644
#ifndef G_OS_WIN32
typedef struct {
-@@ -1355,16 +1371,130 @@ get_content_type (const char *basename,
+@@ -1418,16 +1434,131 @@ get_content_type (const char *basename,
}
@@ -155,16 +155,17 @@ index 487f8cc1a..b0e6db728 100644
- const GLocalFileStat *stat_buf)
+ const GLocalFileStat *stat_buf,
+ gboolean generate)
++
{
GChecksum *checksum;
char *uri;
- char *filename;
+ char *filename = NULL;
char *basename;
+ const char *content_type;
+ const char *size_dirs[4] = { "xx-large", "x-large", "large", "normal" };
+ gsize i;
- uri = g_filename_to_uri (path, NULL, NULL);
-
-@@ -1383,6 +1513,7 @@ get_thumbnail_attributes (const char *path,
+@@ -1455,6 +1586,7 @@ get_thumbnail_attributes (const char *path,
_g_file_info_set_attribute_byte_string_by_id (info, G_FILE_ATTRIBUTE_ID_THUMBNAIL_PATH, filename);
_g_file_info_set_attribute_boolean_by_id (info, G_FILE_ATTRIBUTE_ID_THUMBNAIL_IS_VALID,
thumbnail_verify (filename, uri, stat_buf));
@@ -172,21 +173,12 @@ index 487f8cc1a..b0e6db728 100644
}
else
{
-@@ -1396,6 +1527,7 @@ get_thumbnail_attributes (const char *path,
- _g_file_info_set_attribute_byte_string_by_id (info, G_FILE_ATTRIBUTE_ID_THUMBNAIL_PATH, filename);
+@@ -1469,8 +1601,31 @@ get_thumbnail_attributes (const char *path,
+ _g_file_info_set_attribute_boolean_by_id (info, G_FILE_ATTRIBUTE_ID_THUMBNAILING_FAILED, TRUE);
_g_file_info_set_attribute_boolean_by_id (info, G_FILE_ATTRIBUTE_ID_THUMBNAIL_IS_VALID,
thumbnail_verify (filename, uri, stat_buf));
+ generate = FALSE;
}
- else
- {
-@@ -1411,9 +1543,32 @@ get_thumbnail_attributes (const char *path,
- _g_file_info_set_attribute_boolean_by_id (info, G_FILE_ATTRIBUTE_ID_THUMBNAILING_FAILED, TRUE);
- _g_file_info_set_attribute_boolean_by_id (info, G_FILE_ATTRIBUTE_ID_THUMBNAIL_IS_VALID,
- thumbnail_verify (filename, uri, stat_buf));
-+ generate = FALSE;
- }
- }
}
+
+ if (generate)
@@ -213,7 +205,7 @@ index 487f8cc1a..b0e6db728 100644
g_free (basename);
g_free (filename);
g_free (uri);
-@@ -1767,6 +1922,18 @@ _g_local_file_info_get (const char *basename,
+@@ -1861,6 +2016,18 @@ _g_local_file_info_get (const char *basename,
info = g_file_info_new ();
@@ -232,7 +224,7 @@ index 487f8cc1a..b0e6db728 100644
/* Make sure we don't set any unwanted attributes */
g_file_info_set_attribute_mask (info, attribute_matcher);
-@@ -1901,7 +2068,9 @@ _g_local_file_info_get (const char *basename,
+@@ -1993,7 +2160,9 @@ _g_local_file_info_get (const char *basename,
_g_file_attribute_matcher_matches_id (attribute_matcher,
G_FILE_ATTRIBUTE_ID_STANDARD_ICON) ||
_g_file_attribute_matcher_matches_id (attribute_matcher,
@@ -243,7 +235,7 @@ index 487f8cc1a..b0e6db728 100644
{
char *content_type = get_content_type (basename, path, stat_ok ? &statbuf : NULL, is_symlink, symlink_broken, flags, FALSE);
-@@ -2018,9 +2187,9 @@ _g_local_file_info_get (const char *basename,
+@@ -2110,9 +2279,9 @@ _g_local_file_info_get (const char *basename,
G_FILE_ATTRIBUTE_ID_THUMBNAILING_FAILED))
{
if (stat_ok)