summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--memleak.patch25
3 files changed, 40 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5ae84c6b10f..7e5ec728633a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Dec 12 05:58:46 UTC 2015
pkgbase = glib2-patched-thumbnailer
pkgdesc = GLib2 patched with ahodesuka's thumbnailer patch.
- pkgver = 2.46.1
+ pkgver = 2.46.2
pkgrel = 1
url = http://gist.github.com/ahodesuka/49c1d0eea4b64f24c4c7
arch = i686
@@ -22,12 +24,14 @@ pkgbase = glib2-patched-thumbnailer
conflicts = glib2
options = !docs
options = !emptydirs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.46/glib-2.46.1.tar.xz
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.46/glib-2.46.2.tar.xz
source = revert-warn-glib-compile-schemas.patch
source = https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/d0edf118e1c27700300038c1d82b3ff775c0216b/glib-thumbnailer.patch
- sha256sums = 5a1f03b952ebc3a7e9f612b8724f70898183e31503db329b4f15d07163c8fdfb
+ source = memleak.patch
+ sha256sums = 5031722e37036719c1a09163cc6cf7c326e4c4f1f1e074b433c156862bd733db
sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
sha256sums = 1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d
+ sha256sums = 8337eeba4a32133d41575c8338fca32ac6a867e6e4a4e021355fcdeb606420a6
pkgname = glib2-patched-thumbnailer
diff --git a/PKGBUILD b/PKGBUILD
index 9a2bc133edc9..6aed1731c671 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=glib2-patched-thumbnailer
pkgname=glib2-patched-thumbnailer
-pkgver=2.46.1
+pkgver=2.46.2
_patchver=d0edf118e1c27700300038c1d82b3ff775c0216b
pkgrel=1
pkgdesc="GLib2 patched with ahodesuka's thumbnailer patch."
@@ -19,25 +19,22 @@ options=('!docs' '!emptydirs')
license=('LGPL')
source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver:0:4}/glib-$pkgver.tar.xz
revert-warn-glib-compile-schemas.patch
- https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/$_patchver/glib-thumbnailer.patch)
-sha256sums=('5a1f03b952ebc3a7e9f612b8724f70898183e31503db329b4f15d07163c8fdfb'
+ https://gist.githubusercontent.com/ahodesuka/49c1d0eea4b64f24c4c7/raw/$_patchver/glib-thumbnailer.patch
+ memleak.patch)
+sha256sums=('5031722e37036719c1a09163cc6cf7c326e4c4f1f1e074b433c156862bd733db'
'049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97'
- '1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d')
+ '1a4673380fbdf8e8e5de3367089de6c97025633e54010575de63c5ab6c8a044d'
+ '8337eeba4a32133d41575c8338fca32ac6a867e6e4a4e021355fcdeb606420a6')
prepare() {
cd glib-$pkgver
patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
+ patch -Np1 -i ../memleak.patch
patch -Np1 -i ${srcdir}/glib-thumbnailer.patch
}
-
+
build() {
cd glib-$pkgver
-
- ## Prevent runtime unloading of glib
- # https://bugs.archlinux.org/task/46619
- # https://bugzilla.gnome.org/show_bug.cgi?id=755609
- LDFLAGS+=" -Wl,-z,nodelete"
-
PYTHON=/usr/bin/python2 ./configure --prefix=/usr --libdir=/usr/lib \
--sysconfdir=/etc \
--with-pcre=system \
diff --git a/memleak.patch b/memleak.patch
new file mode 100644
index 000000000000..2b927a10138c
--- /dev/null
+++ b/memleak.patch
@@ -0,0 +1,25 @@
+From db641e32920ee8b553ab6f2d318aafa156e4390c Mon Sep 17 00:00:00 2001
+From: Evangelos Foutras <evangelos@foutrelis.com>
+Date: Wed, 25 Nov 2015 23:29:18 +0200
+Subject: GDBusProxy: Fix a memory leak during initialization
+
+https://bugzilla.gnome.org/show_bug.cgi?id=758641
+---
+ gio/gdbusproxy.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/gio/gdbusproxy.c b/gio/gdbusproxy.c
+index 52a22fb..7b1140f 100644
+--- a/gio/gdbusproxy.c
++++ b/gio/gdbusproxy.c
+@@ -1720,6 +1720,7 @@ async_initable_init_second_finish (GAsyncInitable *initable,
+ if (result != NULL)
+ {
+ process_get_all_reply (proxy, result);
++ g_variant_unref (result);
+ }
+
+ proxy->priv->initialized = TRUE;
+--
+cgit v0.11.2
+