summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD66
-rw-r--r--gio-querymodules.hook11
-rw-r--r--glib-compile-schemas.hook12
-rw-r--r--gmessages-nowarn.patch13
-rw-r--r--revert-warn-glib-compile-schemas.patch33
6 files changed, 169 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a43a6600a3e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = glib2-quiet
+ pkgdesc = A patched version of glib2, with spammy console WARNING messages disabled
+ pkgver = 2.48.2
+ pkgrel = 1
+ url = http://www.gtk.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = pkg-config
+ makedepends = python
+ makedepends = pcre
+ makedepends = libffi
+ makedepends = libelf
+ depends = pcre
+ depends = libffi
+ optdepends = python: for gdbus-codegen and gtester-report
+ optdepends = libelf: gresource inspection tool
+ provides = glib2
+ conflicts = glib2
+ options = !docs
+ options = !emptydirs
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.48/glib-2.48.2.tar.xz
+ source = glib-compile-schemas.hook
+ source = gio-querymodules.hook
+ source = revert-warn-glib-compile-schemas.patch
+ source = gmessages-nowarn.patch
+ sha256sums = f25e751589cb1a58826eac24fbd4186cda4518af772806b666a3f91f66e6d3f4
+ sha256sums = e1123a5d85d2445faac33f6dae1085fdd620d83279a4e130a83fe38db52b62b3
+ sha256sums = 5ba204a2686304b1454d401a39a9d27d09dd25e4529664e3fd565be3d439f8b6
+ sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
+ sha256sums = 3c5d812cd1e8905f89de14b0d5272e733c612a8c47bd648da97a3545a727044a
+
+pkgname = glib2-quiet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30ee33bd2366
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# $Id$
+# Original Maintainer: Jan de Groot <jgc@archlinux.org>
+# Fork Maintainer: epitron <chris@ill-logic.com>
+
+pkgname=glib2-quiet
+pkgver=2.48.2
+pkgrel=1
+pkgdesc="A patched version of glib2, with spammy console WARNING messages disabled"
+url="http://www.gtk.org/"
+arch=(i686 x86_64)
+depends=('pcre' 'libffi')
+optdepends=('python: for gdbus-codegen and gtester-report'
+ 'libelf: gresource inspection tool')
+makedepends=('pkg-config' 'python' 'pcre' 'libffi' 'libelf')
+options=('!docs' '!emptydirs')
+license=('LGPL')
+
+provides=('glib2')
+conflicts=('glib2')
+
+source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver:0:4}/glib-$pkgver.tar.xz
+ glib-compile-schemas.hook
+ gio-querymodules.hook
+ revert-warn-glib-compile-schemas.patch
+ gmessages-nowarn.patch)
+
+sha256sums=('f25e751589cb1a58826eac24fbd4186cda4518af772806b666a3f91f66e6d3f4'
+ 'e1123a5d85d2445faac33f6dae1085fdd620d83279a4e130a83fe38db52b62b3'
+ '5ba204a2686304b1454d401a39a9d27d09dd25e4529664e3fd565be3d439f8b6'
+ '049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97'
+ '3c5d812cd1e8905f89de14b0d5272e733c612a8c47bd648da97a3545a727044a')
+
+prepare() {
+ cd glib-$pkgver
+ patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
+ patch -p1 -i ../gmessages-nowarn.patch
+}
+
+build() {
+ cd glib-$pkgver
+ ./configure --prefix=/usr --libdir=/usr/lib \
+ --sysconfdir=/etc \
+ --with-pcre=system \
+ --disable-fam
+ make
+}
+
+check() {
+ cd glib-$pkgver
+ # Takes an effing long time
+ #make -k check || :
+}
+
+package() {
+ cd glib-$pkgver
+ make completiondir=/usr/share/bash-completion/completions DESTDIR="$pkgdir" install
+
+ chmod -x "$pkgdir"/usr/share/bash-completion/completions/*
+
+ # Our gdb does not ship the required python modules, so remove it
+ rm -r "$pkgdir/usr/share/gdb/"
+
+ # install hooks
+ install -dm755 "$pkgdir"/usr/share/libalpm/hooks/
+ install -m644 "$srcdir"/{glib-compile-schemas,gio-querymodules}.hook "$pkgdir"/usr/share/libalpm/hooks/
+}
diff --git a/gio-querymodules.hook b/gio-querymodules.hook
new file mode 100644
index 000000000000..193233398168
--- /dev/null
+++ b/gio-querymodules.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/gio/modules/*.so
+
+[Action]
+Description = Updating GIO module cache...
+When = PostTransaction
+Exec = /usr/bin/gio-querymodules /usr/lib/gio/modules
diff --git a/glib-compile-schemas.hook b/glib-compile-schemas.hook
new file mode 100644
index 000000000000..04dc59b1a638
--- /dev/null
+++ b/glib-compile-schemas.hook
@@ -0,0 +1,12 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/share/glib-2.0/schemas/*.gschema.xml
+Target = usr/share/glib-2.0/schemas/*.gschema.override
+
+[Action]
+Description = Compiling GSettings XML schema files...
+When = PostTransaction
+Exec = /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
diff --git a/gmessages-nowarn.patch b/gmessages-nowarn.patch
new file mode 100644
index 000000000000..1cd13086dd29
--- /dev/null
+++ b/gmessages-nowarn.patch
@@ -0,0 +1,13 @@
+--- a/glib/gmessages.c 2016-08-17 11:20:47.000000000 -0400
++++ b/glib/gmessages.c 2016-08-26 02:17:21.662120469 -0400
+@@ -973,6 +973,10 @@
+ if (!log_level)
+ return;
+
++ // HACK: Hide all warnings
++ if (log_level & G_LOG_LEVEL_WARNING)
++ return;
++
+ if (log_level & G_LOG_FLAG_RECURSION)
+ {
+ /* we use a stack buffer of fixed size, since we're likely
diff --git a/revert-warn-glib-compile-schemas.patch b/revert-warn-glib-compile-schemas.patch
new file mode 100644
index 000000000000..75b05103cd02
--- /dev/null
+++ b/revert-warn-glib-compile-schemas.patch
@@ -0,0 +1,33 @@
+From 6560b37450cd19c4a7c7b690e279fe97b7bfdcaa Mon Sep 17 00:00:00 2001
+From: Ryan Lortie <desrt@desrt.ca>
+Date: Thu, 12 Apr 2012 23:55:34 +0000
+Subject: glib-compile-schemas: warn about bad dconf paths
+
+For quite some time the recommended usage of GSettings and dconf has
+been to use paths like /org/gnome/example/. Use of /apps/ has spilled
+over from GConf and is continuing to make its way into a number of
+applications as they port.
+
+glib-compile-schemas will now warn about these types of paths being
+used. This generates a lot of noise, but hopefully it will reduce the
+number of ported applications making this mistake.
+---
+diff --git a/gio/glib-compile-schemas.c b/gio/glib-compile-schemas.c
+index cf02389..27d0181 100644
+--- a/gio/glib-compile-schemas.c
++++ b/gio/glib-compile-schemas.c
+@@ -1204,6 +1204,12 @@ parse_state_start_schema (ParseState *state,
+ return;
+ }
+
++ if (path && (g_str_has_prefix (path, "/apps/") ||
++ g_str_has_prefix (path, "/desktop/") ||
++ g_str_has_prefix (path, "/system/")))
++ g_printerr ("warning: Schema '%s' has path '%s'. Paths starting with "
++ "'/apps/', '/desktop/' or '/system/' are deprecated.\n", id, path);
++
+ state->schema_state = schema_state_new (path, gettext_domain,
+ extends, extends_name, list_of);
+
+--
+cgit v0.9.0.2