summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD25
2 files changed, 32 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e047b4845c5e..65d19ab435f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,32 @@
+# Generated by mksrcinfo v8
+# Do Feb 9 12:35:15 UTC 2017
pkgbase = glib2-static
- pkgdesc = Common C routines used by GTK+ and other libs
- pkgver = 2.44.0
+ pkgdesc = Low level core library. Static library.
+ pkgver = 2.50.2
pkgrel = 1
url = http://www.gtk.org/
arch = i686
arch = x86_64
license = LGPL
- makedepends = pkg-config
- makedepends = python2
- makedepends = libxslt
- makedepends = docbook-xml
- makedepends = pcre
+ checkdepends = desktop-file-utils
+ checkdepends = dbus
makedepends = libffi
- makedepends = elfutils
+ makedepends = pcre
+ makedepends = zlib
+ makedepends = shared-mime-info
+ makedepends = python
+ makedepends = libelf
depends = pcre
depends = libffi
- depends = glib2
optdepends = python2: for gdbus-codegen and gtester-report
optdepends = elfutils: gresource inspection tool
options = !docs
options = !libtool
options = !emptydirs
options = staticlibs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.44/glib-2.44.0.tar.xz
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.50/glib-2.50.2.tar.xz
source = revert-warn-glib-compile-schemas.patch
- sha256sums = f2d362b106a08fa801770d41829a06fcfe287a00421018869eebf5efc796f5b9
+ sha256sums = be68737c1f268c05493e503b3b654d2b7f43d7d0b8c5556f7e4651b870acfbf5
sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
pkgname = glib2-static
diff --git a/PKGBUILD b/PKGBUILD
index e9c04c236477..d4920ea7d57f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
pkgname=glib2-static
-pkgver=2.44.0
+pkgver=2.50.2
pkgrel=1
-pkgdesc="Common C routines used by GTK+ and other libs"
+pkgdesc="Low level core library. Static library."
url="http://www.gtk.org/"
arch=(i686 x86_64)
-depends=('pcre' 'libffi' "glib2")
-makedepends=('pkg-config' 'python2' 'libxslt' 'docbook-xml' 'pcre' 'libffi' 'elfutils')
+makedepends=(libffi pcre zlib shared-mime-info python libelf)
+checkdepends=(desktop-file-utils dbus)
optdepends=('python2: for gdbus-codegen and gtester-report'
'elfutils: gresource inspection tool')
options=('!docs' '!libtool' '!emptydirs' 'staticlibs')
-license=('LGPL')
+depends=(pcre libffi)
+license=(LGPL)
source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.tar.xz
revert-warn-glib-compile-schemas.patch)
-sha256sums=('f2d362b106a08fa801770d41829a06fcfe287a00421018869eebf5efc796f5b9'
+sha256sums=('be68737c1f268c05493e503b3b654d2b7f43d7d0b8c5556f7e4651b870acfbf5'
'049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
prepare() {
cd glib-$pkgver
patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
@@ -26,9 +28,20 @@ build() {
--sysconfdir=/etc \
--with-pcre=system \
--disable-fam --enable-static
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
+check() {
+ cd glib-$pkgver
+ if ! make check; then
+ # Rounding error in timer tests?
+ # GLib:ERROR:timer.c:38:test_timer_basic: assertion failed (micros == ((guint64)(elapsed * 1e6)) % 1000000): (1 == 0)
+ make check
+ fi
+}
+
+
package() {
cd glib-$pkgver
make completiondir=/usr/share/bash-completion/completions DESTDIR="$pkgdir" install