summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch8
-rw-r--r--PKGBUILD6
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0d68b7847eb..75b6348e6974 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = glibc-git
pkgdesc = GNU C Library
- pkgver = 2.28.r164.g81dca813cc
+ pkgver = 2.28.r261.g6d6ee04622
pkgrel = 1
url = https://www.gnu.org/software/libc/
install = glibc-git.install
@@ -10,6 +10,7 @@ pkgbase = glibc-git
license = GPL
license = LGPL
makedepends = git
+ makedepends = python
depends = linux-api-headers
depends = tzdata
depends = filesystem
@@ -25,7 +26,7 @@ pkgbase = glibc-git
source = bz20338.patch
sha256sums = SKIP
sha256sums = 05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de
- sha256sums = dd717ee59e778d808545f4f3f3f436bfc678a2d3937589d649b70767025e7e1e
+ sha256sums = a1973bc50a3cd80aa1745de0622a8496d185b9a16fceb1f3adbe33eb1aafb18b
sha256sums = 959d4f41edd004bddd9091c4d8c8c3aa07d79a04bfdb89d59f9f26fe5a74d32a
pkgname = glibc-git
diff --git a/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
index 15f8b73c3958..780058f84467 100644
--- a/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
+++ b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
@@ -1,4 +1,4 @@
-From 098e7db144012cbd19d359df3847461dc0c58514 Mon Sep 17 00:00:00 2001
+From e4d9bb4a08f3ad518f0f54163f3043ca72c593e3 Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz@archlinux.org>
Date: Fri, 28 Sep 2018 05:19:46 +0000
Subject: [PATCH] Revert "elf: Correct absolute (SHN_ABS) symbol run-time
@@ -18,7 +18,7 @@ This reverts commit e7feec374c635b6a29d65c39ae5e1855528fed39.
delete mode 100644 elf/tst-absolute-sym.c
diff --git a/elf/Makefile b/elf/Makefile
-index 455ec730fc..4560718fe2 100644
+index d72e7b67f6..91fd26973d 100644
--- a/elf/Makefile
+++ b/elf/Makefile
@@ -186,7 +186,7 @@ tests += restest1 preloadtest loadfail multiload origtest resolvfail \
@@ -27,7 +27,7 @@ index 455ec730fc..4560718fe2 100644
tst-latepthread tst-tls-manydynamic tst-nodelete-dlclose \
- tst-debug1 tst-main1 tst-absolute-sym tst-absolute-zero tst-big-note \
+ tst-debug1 tst-main1 tst-absolute-zero tst-big-note \
- tst-unwind-ctor
+ tst-unwind-ctor tst-unwind-main
# reldep9
tests-internal += loadtest unload unload2 circleload1 \
@@ -273,7 +273,7 @@ modules-names = testobj1 testobj2 testobj3 testobj4 testobj5 testobj6 \
@@ -174,5 +174,5 @@ index 95dc87519b..3cac4fa362 100644
/* On some architectures a pointer to a function is not just a pointer
to the actual code of the function but rather an architecture
--
-2.19.0
+2.19.1
diff --git a/PKGBUILD b/PKGBUILD
index 9dbc10d8f91a..bedebe901f8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=glibc-git
-pkgver=2.28.r164.g81dca813cc
+pkgver=2.28.r261.g6d6ee04622
pkgrel=1
pkgdesc='GNU C Library'
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ license=('GPL' 'LGPL')
groups=('base')
depends=('linux-api-headers' 'tzdata' 'filesystem')
optdepends=('gd: graph image generation with memusage')
-makedepends=('git')
+makedepends=('git' 'python')
# XXX Arch Linux's valgrind package requires an exact version
provides=("glibc=${pkgver%%.r*}")
conflicts=('glibc')
@@ -26,7 +26,7 @@ source=('git+https://sourceware.org/git/glibc.git'
'bz20338.patch')
sha256sums=('SKIP'
'05fbb88877cdddc99ef25e48304d6e5ac236660c20925d461cb4e90ebcb3b7de'
- 'dd717ee59e778d808545f4f3f3f436bfc678a2d3937589d649b70767025e7e1e'
+ 'a1973bc50a3cd80aa1745de0622a8496d185b9a16fceb1f3adbe33eb1aafb18b'
'959d4f41edd004bddd9091c4d8c8c3aa07d79a04bfdb89d59f9f26fe5a74d32a')
pkgver() {