summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--floating_wm_workaround.patch12
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 121b1f9d1716..fc16f9c612e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = glslviewer-git
pkgdesc = Live GLSL coding render for MacOS and Linux
- pkgver = r551.4858c45
+ pkgver = r753.8a4f4d7
pkgrel = 1
url = https://github.com/patriciogonzalezvivo/glslViewer
arch = i686
@@ -13,7 +13,7 @@ pkgbase = glslviewer-git
source = glslviewer-git::git+https://github.com/patriciogonzalezvivo/glslViewer
source = floating_wm_workaround.patch
md5sums = SKIP
- md5sums = dd0001eb24fdf2cd1f49e83b25ba2fd7
+ md5sums = 20c838d28b2390c9dd6fa3491c920edc
pkgname = glslviewer-git
diff --git a/PKGBUILD b/PKGBUILD
index 5552097b28ca..83af8d828f48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Agorgianitis Loukas <agorglouk@gmail.com>
pkgname=glslviewer-git
-pkgver=r551.4858c45
+pkgver=r753.8a4f4d7
pkgrel=1
pkgdesc="Live GLSL coding render for MacOS and Linux"
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ conflicts=("${pkgname%-VCS}")
source=("$pkgname::git+https://github.com/patriciogonzalezvivo/glslViewer"
'floating_wm_workaround.patch')
md5sums=('SKIP'
- 'dd0001eb24fdf2cd1f49e83b25ba2fd7')
+ '20c838d28b2390c9dd6fa3491c920edc')
pkgver() {
cd "$srcdir/${pkgname%-VCS}"
diff --git a/floating_wm_workaround.patch b/floating_wm_workaround.patch
index d0cdc2005ab5..64c4fcc0e220 100644
--- a/floating_wm_workaround.patch
+++ b/floating_wm_workaround.patch
@@ -1,14 +1,14 @@
diff --git a/src/window.cpp b/src/window.cpp
-index 66cf765..fc8f44c 100644
+index 7b5eb06..d3f6a09 100644
--- a/src/window.cpp
+++ b/src/window.cpp
-@@ -204,6 +204,9 @@ void initGL (glm::ivec4 &_viewport, bool _headless, bool _alwaysOnTop) {
+@@ -416,6 +416,9 @@ void initGL (glm::ivec4 &_viewport, WindowStyle _style) {
+ else if (_style == ALLWAYS_ON_TOP)
glfwWindowHint(GLFW_FLOATING, GL_TRUE);
- }
+ // Make it float
+ glfwWindowHint(GLFW_RESIZABLE, GLFW_FALSE);
+
- window = glfwCreateWindow(_viewport.z, _viewport.w, appTitle.c_str(), NULL, NULL);
-
- if(!window) {
+ if (_style == FULLSCREEN) {
+ GLFWmonitor* monitor = glfwGetPrimaryMonitor();
+ const GLFWvidmode* mode = glfwGetVideoMode(monitor);