summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--floating_wm_workaround.patch14
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c97d313181f1..6efbc0f69c80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = glslviewer-git
source = glslviewer-git::git+https://github.com/patriciogonzalezvivo/glslViewer
source = floating_wm_workaround.patch
md5sums = SKIP
- md5sums = 0d5e68722253fd33a25e57d7e2405a5c
+ md5sums = dd0001eb24fdf2cd1f49e83b25ba2fd7
pkgname = glslviewer-git
diff --git a/PKGBUILD b/PKGBUILD
index 966ddc414bc0..8a524edf10a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Agorgianitis Loukas <agorglouk@gmail.com>
pkgname=glslviewer-git
-pkgver=r425.8d5effb
+pkgver=r551.4858c45
pkgrel=1
pkgdesc="Live GLSL coding render for MacOS and Linux"
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ conflicts=("${pkgname%-VCS}")
source=("$pkgname::git+https://github.com/patriciogonzalezvivo/glslViewer"
'floating_wm_workaround.patch')
md5sums=('SKIP'
- '0d5e68722253fd33a25e57d7e2405a5c')
+ 'dd0001eb24fdf2cd1f49e83b25ba2fd7')
pkgver() {
cd "$srcdir/${pkgname%-VCS}"
diff --git a/floating_wm_workaround.patch b/floating_wm_workaround.patch
index 31972a18325f..d0cdc2005ab5 100644
--- a/floating_wm_workaround.patch
+++ b/floating_wm_workaround.patch
@@ -1,14 +1,14 @@
-diff --git a/src/app.cpp b/src/app.cpp
-index 35d06a3..3e33eb7 100644
---- a/src/app.cpp
-+++ b/src/app.cpp
-@@ -175,6 +175,9 @@ void initGL (glm::ivec4 &_viewport, bool _headless) {
- glfwWindowHint(GLFW_VISIBLE, GLFW_FALSE);
+diff --git a/src/window.cpp b/src/window.cpp
+index 66cf765..fc8f44c 100644
+--- a/src/window.cpp
++++ b/src/window.cpp
+@@ -204,6 +204,9 @@ void initGL (glm::ivec4 &_viewport, bool _headless, bool _alwaysOnTop) {
+ glfwWindowHint(GLFW_FLOATING, GL_TRUE);
}
+ // Make it float
+ glfwWindowHint(GLFW_RESIZABLE, GLFW_FALSE);
+
window = glfwCreateWindow(_viewport.z, _viewport.w, appTitle.c_str(), NULL, NULL);
-
+
if(!window) {