summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD39
2 files changed, 31 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b4727fd7b5e..4416b8d0cce6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = gm-companion
pkgdesc = A tool for rpg gamemasters.
- pkgver = 1.1.0
+ pkgver = 1.2.1
pkgrel = 1
url = https://gm-companion.github.io/
arch = x86_64
arch = i686
license = GPL3
- makedepends = gendesk
- depends = qt5-declarative>=5.10.0,
- depends = qt5-graphicaleffects>=5.10.0,
- depends = qt5-multimedia>=5.10.0,
- depends = qt5-networkauth>=5.10.0,
- depends = qt5-quickcontrols2>=5.10.0,
- depends = poppler-qt5
+ makedepends = cmake
+ depends = qt6-base>=6.5.0
+ depends = qt6-5compat>=6.5.0
+ depends = qt6-declarative>=6.5.0
+ depends = qt6-multimedia>=6.5.0
+ depends = qt6-tools>=6.5.0
+ depends = poppler-qt6
+ depends = qtkeychain-qt6
+ depends = quazip-qt6
+ depends = discount
+ depends = taglib
+ optdepends = librespot: Spotify support
conflicts = gm-companion-git
- source = https://github.com/PhilInTheGaps/GM-Companion/releases/download/1.1.0/source_with_submodules.tar.xz
- source = https://raw.githubusercontent.com/PhilInTheGaps/GM-Companion/ubuntu-build/data/share/gm-companion/icon256.png
- md5sums = 83e5a514cabefcb33495cd4b293479e5
- md5sums = 877a226689a5edaee3ecfdaf767ded9d
+ source = https://github.com/PhilInTheGaps/GM-Companion/releases/download/1.2.1/gm-companion_1.2.1.tar.gz
+ sha512sums = 65cd814b3b5dcaa77e2c09e84dab2397be50264f4580b42cded33b69c59138c5cd0a692f312f15af8d201074e5c487133746643b1d13cb725f04dc61754b9a29
pkgname = gm-companion
-
diff --git a/PKGBUILD b/PKGBUILD
index f7da25925514..88374a5d0b8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,32 @@
# Maintainer: Phil Hoffmann <phil dot hoffmann at zoho dot eu>
pkgname=gm-companion
-pkgver=1.1.0
+pkgver=1.2.1
pkgrel=1
pkgdesc="A tool for rpg gamemasters."
url="https://gm-companion.github.io/"
arch=('x86_64' 'i686')
license=('GPL3')
-depends=('qt5-declarative>=5.10.0', 'qt5-graphicaleffects>=5.10.0', 'qt5-multimedia>=5.10.0', 'qt5-networkauth>=5.10.0', 'qt5-quickcontrols2>=5.10.0', 'poppler-qt5')
-makedepends=('gendesk')
+depends=('qt6-base>=6.5.0' 'qt6-5compat>=6.5.0' 'qt6-declarative>=6.5.0' 'qt6-multimedia>=6.5.0' 'qt6-tools>=6.5.0' 'poppler-qt6' 'qtkeychain-qt6' 'quazip-qt6' 'discount' 'taglib')
+optdepends=('librespot: Spotify support')
+makedepends=('cmake')
conflicts=('gm-companion-git')
-source=("https://github.com/PhilInTheGaps/GM-Companion/releases/download/${pkgver}/source_with_submodules.tar.xz" "https://raw.githubusercontent.com/PhilInTheGaps/GM-Companion/ubuntu-build/data/share/gm-companion/icon256.png")
-md5sums=('83e5a514cabefcb33495cd4b293479e5'
- '877a226689a5edaee3ecfdaf767ded9d')
-
-prepare() {
- gendesk -n -f --name='GM-Companion' --pkgname "$pkgname" --pkgdesc "$pkgdesc"
-}
+source=("https://github.com/PhilInTheGaps/GM-Companion/releases/download/${pkgver}/gm-companion_${pkgver}.tar.gz")
+sha512sums=('65cd814b3b5dcaa77e2c09e84dab2397be50264f4580b42cded33b69c59138c5cd0a692f312f15af8d201074e5c487133746643b1d13cb725f04dc61754b9a29')
build() {
- cd "${srcdir}"
- qmake
- make PREFIX=/usr
-
+ cd "${srcdir}/gm-companion_${pkgver}"
+ mkdir build
+ cd build
+ cmake .. -D CMAKE_BUILD_TYPE=Release -D CMAKE_INSTALL_PREFIX="${pkgdir}/usr" -DCMAKE_UNITY_BUILD=ON
+ cmake --build . --parallel
}
package() {
- # Install main binary
- cd "${srcdir}"
- make INSTALL_ROOT="$pkgdir" install
-
- # Desktop Entry
- install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
-
- # Icon
- install -Dm644 "$srcdir/icon256.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ cd "${srcdir}/gm-companion_${pkgver}/build"
+ cmake --install .
+
+ rm -rf "${pkgdir}/usr/include"
+ rm -rf "${pkgdir}/usr/lib"
}