summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..569e608eb170
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gmchess-bin
+ pkgdesc = Play Chinese chess (Xiangqi) against a human opponent or the computer
+ pkgver = 0.29.6
+ pkgrel = 1
+ url = http://www.xqbase.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = libarchive
+ depends = gtkmm
+ depends = eleeye-bin
+ conflicts = gmchess
+ source_i686 = http://security.ubuntu.com/ubuntu/pool/universe/g/gmchess/gmchess_0.29.6-3_i386.deb
+ sha1sums_i686 = cb855268b688189d52be9b42febfc31be3962e2f
+ source_x86_64 = http://security.ubuntu.com/ubuntu/pool/universe/g/gmchess/gmchess_0.29.6-3_amd64.deb
+ sha1sums_x86_64 = b2bd7d9167901f057a7e2307d282055184915b91
+
+pkgname = gmchess-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02cfc7f0011d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: mrxx <mrxx at cyberhome dot at>
+
+_debpkg=gmchess
+pkgname=gmchess-bin
+pkgver=0.29.6
+pkgrel=1
+pkgdesc="Play Chinese chess (Xiangqi) against a human opponent or the computer"
+arch=("i686" "x86_64")
+url="http://www.xqbase.com/"
+license=('GPL2')
+depends=('gtkmm' 'eleeye-bin')
+conflicts=('gmchess')
+makedepends=('libarchive')
+source_x86_64=("http://security.ubuntu.com/ubuntu/pool/universe/g/gmchess/${_debpkg}_${pkgver}-3_amd64.deb")
+source_i686=("http://security.ubuntu.com/ubuntu/pool/universe/g/gmchess/${_debpkg}_${pkgver}-3_i386.deb")
+sha1sums_i686=('cb855268b688189d52be9b42febfc31be3962e2f')
+sha1sums_x86_64=('b2bd7d9167901f057a7e2307d282055184915b91')
+
+prepare() {
+ bsdtar xf data.tar.xz
+}
+
+package(){
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/usr/share
+ install -Dm755 $srcdir/usr/games/gmchess $pkgdir/usr/bin
+ cp -r "$srcdir/usr/share" "$pkgdir/usr/"
+}