summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--0001-Use-GPR.Sinput.Reference_Name.patch30
-rw-r--r--0002-Ignore-absence-of-version-number-in-user_guide.patch28
-rw-r--r--0003-Honour-DESTDIR-in-installation-targets.patch (renamed from 0001-Honour-DESTDIR-in-installation-targets.patch)0
-rw-r--r--0004-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch (renamed from 0002-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch)0
-rw-r--r--0005-Fix-recursive-make-in-docs.patch50
-rw-r--r--PKGBUILD61
7 files changed, 157 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67c4d46c38f7..323190b3d8ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnat-gps
pkgdesc = GNAT Programming Studio for Ada
pkgver = 2020
- pkgrel = 4
+ pkgrel = 3
url = https://github.com/AdaCore/gps
arch = i686
arch = x86_64
@@ -22,17 +22,23 @@ pkgbase = gnat-gps
depends = gnome-icon-theme-symbolic
depends = python2-gobject
optdepends = python2-jedi
- source = https://community.download.adacore.com/v1/bfa68dd61a9288c79e9c08676878cac95e0fe628?filename=gps-21.0w-20200427-15496-src.tar.gz
- source = https://community.download.adacore.com/v1/05e31f6e36e2ff4313013d27f0551416de5a1b4e?filename=als-21.0w-20200427-156B6-src.tar.gz
- source = https://community.download.adacore.com/v1/334dca036084a92552860451619321faee571797?filename=libadalang-tools-_laltools_ver-src.tar.gz
- source = 0001-Honour-DESTDIR-in-installation-targets.patch
- source = 0002-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch
+ source = gps-1b841d995bd6171f2462cad4a00c34cb6989fa7b.tar.gz::https://github.com/AdaCore/gps/archive/1b841d995bd6171f2462cad4a00c34cb6989fa7b.tar.gz
+ source = ada_language_server-21.0.3.tar.gz::https://github.com/AdaCore/ada_language_server/archive/21.0.3.tar.gz
+ source = libadalang-tools-2020-20200429-1998C-src.tar.gz::https://community.download.adacore.com/v1/740372d8ffb1e4755a99bead2d78dace904235c0?filename=libadalang-tools-2020-20200429-1998C-src.tar.gz
+ source = 0001-Use-GPR.Sinput.Reference_Name.patch
+ source = 0002-Ignore-absence-of-version-number-in-user_guide.patch
+ source = 0003-Honour-DESTDIR-in-installation-targets.patch
+ source = 0004-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch
+ source = 0005-Fix-recursive-make-in-docs.patch
source = gps.desktop
- sha1sums = bfa68dd61a9288c79e9c08676878cac95e0fe628
- sha1sums = 05e31f6e36e2ff4313013d27f0551416de5a1b4e
- sha1sums = 334dca036084a92552860451619321faee571797
+ sha1sums = 357780e1155b38a5ff8b5a4c9b088f88682860d4
+ sha1sums = a737b6d7ee2d4a1193f088a0817070e545752dae
+ sha1sums = 740372d8ffb1e4755a99bead2d78dace904235c0
+ sha1sums = 7befc021358ada26c6a332e623113b32317bfd8c
+ sha1sums = 525f0b9d64fecb9c2e669cf64b60548b86c575d9
sha1sums = 4c13859aa25c5142bd5d0fde7b645217ddeccb50
sha1sums = 26f6fac439ec973facccee5412dc4c86b7c6d8c7
+ sha1sums = 6dd1f880f55c9612a2a67d41e6606df26cd829c6
sha1sums = b399c7b3a1fe48152da18081def3dced2e74763b
pkgname = gnat-gps
diff --git a/0001-Use-GPR.Sinput.Reference_Name.patch b/0001-Use-GPR.Sinput.Reference_Name.patch
new file mode 100644
index 000000000000..9b12c3cf372a
--- /dev/null
+++ b/0001-Use-GPR.Sinput.Reference_Name.patch
@@ -0,0 +1,30 @@
+From d386fd1f73ee5526c866e98e712ca2a8c8b49096 Mon Sep 17 00:00:00 2001
+From: Dmitriy Anisimkov <anisimko@adacore.com>
+Date: Wed, 5 Feb 2020 15:58:58 +0600
+Subject: [PATCH 1/5] Use GPR.Sinput.Reference_Name
+
+T117-002
+
+Prepare to hide Source_File table.
+
+Change-Id: I3c7378061398e1e15c3a1ef18e25c525d437f4fe
+---
+ toolchains_editor/core/src/toolchains-parsers.adb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/toolchains_editor/core/src/toolchains-parsers.adb b/toolchains_editor/core/src/toolchains-parsers.adb
+index b95205057e..dd0314c691 100644
+--- a/toolchains_editor/core/src/toolchains-parsers.adb
++++ b/toolchains_editor/core/src/toolchains-parsers.adb
+@@ -672,7 +672,7 @@ package body Toolchains.Parsers is
+ is
+ Location : constant Source_Ptr := Location_Of (Node, Node_Data);
+ File : constant String := Get_Name_String
+- (Source_File.Table (Get_Source_File_Index (Location)).File_Name);
++ (Reference_Name (Get_Source_File_Index (Location)));
+ Line : constant Line_Number :=
+ Get_Line_Number (Location);
+ Col : constant Column_Number := Get_Column_Number (Location);
+--
+2.26.2
+
diff --git a/0002-Ignore-absence-of-version-number-in-user_guide.patch b/0002-Ignore-absence-of-version-number-in-user_guide.patch
new file mode 100644
index 000000000000..adcb6da0567a
--- /dev/null
+++ b/0002-Ignore-absence-of-version-number-in-user_guide.patch
@@ -0,0 +1,28 @@
+From eab7a24b8e74f37d37522263655363e5647497b4 Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Sun, 24 May 2020 11:22:31 +0200
+Subject: [PATCH 2/5] Ignore absence of version number in user_guide
+
+This was missed in 5b1ce178efb54d8c451c08c8443bbafdea4cacda, "Ignore
+absence of VERSION.txt file."
+---
+ gnatdoc/docs/users_guide/conf.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/gnatdoc/docs/users_guide/conf.py b/gnatdoc/docs/users_guide/conf.py
+index e8f76eaa6c..4076ff8f21 100644
+--- a/gnatdoc/docs/users_guide/conf.py
++++ b/gnatdoc/docs/users_guide/conf.py
+@@ -53,7 +53,8 @@ def get_version():
+ version_file = "../../../VERSION.txt"
+ if os.path.isfile(version_file):
+ return file(version_file).readline()
+- raise Exception("Cannot find version number")
++ else:
++ return "0.0"
+
+ # The version info for the project you're documenting, acts as replacement for
+ # |version| and |release|, also used in various other places throughout the
+--
+2.26.2
+
diff --git a/0001-Honour-DESTDIR-in-installation-targets.patch b/0003-Honour-DESTDIR-in-installation-targets.patch
index 303d220e6768..303d220e6768 100644
--- a/0001-Honour-DESTDIR-in-installation-targets.patch
+++ b/0003-Honour-DESTDIR-in-installation-targets.patch
diff --git a/0002-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch b/0004-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch
index f4bf3650017b..f4bf3650017b 100644
--- a/0002-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch
+++ b/0004-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch
diff --git a/0005-Fix-recursive-make-in-docs.patch b/0005-Fix-recursive-make-in-docs.patch
new file mode 100644
index 000000000000..ca364014a931
--- /dev/null
+++ b/0005-Fix-recursive-make-in-docs.patch
@@ -0,0 +1,50 @@
+From 4266bc917d79d20200d2873f7db110d9827250cb Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Sun, 24 May 2020 11:24:25 +0200
+Subject: [PATCH 5/5] Fix recursive make in docs
+
+---
+ docs/Makefile.in | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/docs/Makefile.in b/docs/Makefile.in
+index 16e273e7f7..311a49c7de 100644
+--- a/docs/Makefile.in
++++ b/docs/Makefile.in
+@@ -12,26 +12,26 @@ all: ug tutorial pg relnotes gnatdoc
+ static:
+
+ pg:
+- make -C programmers_guide html
++ $(MAKE) -C programmers_guide html
+
+ relnotes:
+- make -C release_notes singlehtml
++ $(MAKE) -C release_notes singlehtml
+
+ relnotes_17:
+- make -C release_notes_17 singlehtml
++ $(MAKE) -C release_notes_17 singlehtml
+
+ relnotes_62:
+- make -C release_notes_62 singlehtml
++ $(MAKE) -C release_notes_62 singlehtml
+
+ ug:
+- make -C users_guide html latexpdf
++ $(MAKE) -C users_guide html latexpdf
+
+ gnatdoc:
+- make -C ../gnatdoc/docs/users_guide html latexpdf
++ $(MAKE) -C ../gnatdoc/docs/users_guide html latexpdf
+
+ .PHONY: tutorial
+ tutorial:
+- make -C tutorial html
++ $(MAKE) -C tutorial html
+
+ install:
+ $(MKDIR) $(docdir)
+--
+2.26.2
+
diff --git a/PKGBUILD b/PKGBUILD
index f8bab376f3a2..6b4c973a989d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,8 @@
pkgname=gnat-gps
pkgver=2020
-pkgrel=4
+pkgrel=3
+_gps_version="1b841d995bd6171f2462cad4a00c34cb6989fa7b"
pkgdesc="GNAT Programming Studio for Ada"
arch=('i686' 'x86_64')
@@ -20,30 +21,41 @@ depends=("clang" "libadalang"
optdepends=('python2-jedi')
makedepends=('gprbuild' 'python2-sphinx' 'texlive-latexextra' 'graphviz')
-_gps_version="21.0w-20200427-15496"
-_laltools_ver=21.0w-20200425-15675
-_als_ver=21.0w-20200427-156B6
-
-source=("https://community.download.adacore.com/v1/bfa68dd61a9288c79e9c08676878cac95e0fe628?filename=gps-$_gps_version-src.tar.gz"
- "https://community.download.adacore.com/v1/05e31f6e36e2ff4313013d27f0551416de5a1b4e?filename=als-$_als_ver-src.tar.gz"
- "https://community.download.adacore.com/v1/334dca036084a92552860451619321faee571797?filename=libadalang-tools-_laltools_ver-src.tar.gz"
- 0001-Honour-DESTDIR-in-installation-targets.patch
- 0002-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch
+_laltools_ver=2020-20200429-1998C
+_laltools_checksum=740372d8ffb1e4755a99bead2d78dace904235c0
+# later a_l_s versions are incompatible with GPS 20.2 because of:
+# https://github.com/AdaCore/ada_language_server/commit/6f356e0c522313acedbdf8cbef8908399f46a6cf
+# https://github.com/AdaCore/ada_language_server/commit/24f8c81c4ec238632ceb6a60b664c2707a3e70be (https://github.com/AdaCore/gps/issues/97)
+_als_ver=21.0.3
+source=("gps-${_gps_version}.tar.gz::https://github.com/AdaCore/gps/archive/$_gps_version.tar.gz"
+ "ada_language_server-$_als_ver.tar.gz::https://github.com/AdaCore/ada_language_server/archive/$_als_ver.tar.gz"
+ "libadalang-tools-$_laltools_ver-src.tar.gz::https://community.download.adacore.com/v1/$_laltools_checksum?filename=libadalang-tools-$_laltools_ver-src.tar.gz"
+ 0001-Use-GPR.Sinput.Reference_Name.patch
+ 0002-Ignore-absence-of-version-number-in-user_guide.patch
+ 0003-Honour-DESTDIR-in-installation-targets.patch
+ 0004-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch
+ 0005-Fix-recursive-make-in-docs.patch
gps.desktop)
-sha1sums=('bfa68dd61a9288c79e9c08676878cac95e0fe628'
- '05e31f6e36e2ff4313013d27f0551416de5a1b4e'
- "334dca036084a92552860451619321faee571797"
+sha1sums=('357780e1155b38a5ff8b5a4c9b088f88682860d4'
+ 'a737b6d7ee2d4a1193f088a0817070e545752dae'
+ "$_laltools_checksum"
+ '7befc021358ada26c6a332e623113b32317bfd8c'
+ '525f0b9d64fecb9c2e669cf64b60548b86c575d9'
'4c13859aa25c5142bd5d0fde7b645217ddeccb50'
'26f6fac439ec973facccee5412dc4c86b7c6d8c7'
+ '6dd1f880f55c9612a2a67d41e6606df26cd829c6'
'b399c7b3a1fe48152da18081def3dced2e74763b')
prepare()
{
- cd "$srcdir/gps-$_gps_version-src"
+ cd "$srcdir/gps-$_gps_version"
- patch -p1 < "$srcdir/0001-Honour-DESTDIR-in-installation-targets.patch"
- patch -p1 < "$srcdir/0002-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch"
+ patch -p1 < "$srcdir/0001-Use-GPR.Sinput.Reference_Name.patch"
+ patch -p1 < "$srcdir/0002-Ignore-absence-of-version-number-in-user_guide.patch"
+ patch -p1 < "$srcdir/0003-Honour-DESTDIR-in-installation-targets.patch"
+ patch -p1 < "$srcdir/0004-Honour-GPRBUILD_FLAGS-in-cli-Makefile.patch"
+ patch -p1 < "$srcdir/0005-Fix-recursive-make-in-docs.patch"
# Force use of python2
rm -fr temp_bin
@@ -53,34 +65,29 @@ prepare()
ln -s /usr/bin/sphinx-build2 temp_bin/sphinx-build
# Link libadalang-tools and ada_language_server into the GPS source tree
- ln -sf "$srcdir/libadalang-tools-$_laltools_ver-src" "$srcdir/gps-$_gps_version-src/laltools"
- ln -sf "$srcdir/als-$_als_ver-src" "$srcdir/gps-$_gps_version-src/ada_language_server"
+ ln -sf "$srcdir/libadalang-tools-$_laltools_ver-src" "$srcdir/gps-$_gps_version/laltools"
+ ln -sf "$srcdir/ada_language_server-$_als_ver" "$srcdir/gps-$_gps_version/ada_language_server"
}
build()
{
- cd "$srcdir/gps-$_gps_version-src"
+ cd "$srcdir/gps-$_gps_version"
export OS=unix
# Force use of python2
- export PATH="$srcdir/gps-$_gps_version-src/temp_bin:$PATH"
-
- # Build fails when -O2 flag is used, so we use -O1
- export CFLAGS="-march=x86-64 -mtune=generic -O1 -pipe -fno-plt"
+ export PATH="$srcdir/gps-$_gps_version/temp_bin:$PATH"
./configure --prefix=/usr
make PROCESSORS=0 Build=Production GPRBUILD_FLAGS="-R -cargs $CFLAGS -largs $LDFLAGS -gargs"
-
- export CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt"
- make docs all
+ make -C docs all
}
package()
{
- cd "$srcdir/gps-$_gps_version-src"
+ cd "$srcdir/gps-$_gps_version"
export OS=unix