summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
-rw-r--r--remove-os.patch46
3 files changed, 66 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dec5bb3e9627..0fe15943c981 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnatcoll-core-git
pkgdesc = GNAT Components Collection - Core packages
- pkgver = r2835.ed921e27
- pkgrel = 2
+ pkgver = r3121.78b9de8c
+ pkgrel = 1
url = https://github.com/AdaCore/gnatcoll-core/
arch = i686
arch = x86_64
@@ -14,7 +14,9 @@ pkgbase = gnatcoll-core-git
conflicts = gnatcoll-core
conflicts = gnatcoll
source = git+https://github.com/AdaCore/gnatcoll-core.git
+ source = remove-os.patch
sha1sums = SKIP
+ sha1sums = 5e22130f6cb04bfdffb930c29e0abbda7be53514
pkgname = gnatcoll-core-git
diff --git a/PKGBUILD b/PKGBUILD
index f1dd0a4b6782..8c888c78ee9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
pkgname=gnatcoll-core-git
-pkgver=r2835.ed921e27
-pkgrel=2
+pkgver=r3121.78b9de8c
+pkgrel=1
pkgdesc='GNAT Components Collection - Core packages'
url='https://github.com/AdaCore/gnatcoll-core/'
@@ -15,8 +15,10 @@ makedepends=('git' 'gprbuild')
provides=('gnatcoll-core')
conflicts=('gnatcoll-core' 'gnatcoll')
-source=('git+https://github.com/AdaCore/gnatcoll-core.git')
-sha1sums=('SKIP')
+source=('git+https://github.com/AdaCore/gnatcoll-core.git'
+ 'remove-os.patch')
+sha1sums=('SKIP'
+ '5e22130f6cb04bfdffb930c29e0abbda7be53514')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -25,6 +27,16 @@ pkgver() {
"$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # TODO: The new GNATCOLL.OS.* packages depend on new runtime features (for
+ # instance: Interfaces.C.unsigned_long_long). These will be available only
+ # in future GCC releases (11 and later), so just do without them for now.
+ patch -Np1 -i "$srcdir/remove-os.patch"
+ rm src/os/gnatcoll-os-*
+}
+
build()
{
cd "$srcdir/${pkgname%-git}"
diff --git a/remove-os.patch b/remove-os.patch
new file mode 100644
index 000000000000..c118a73c8afa
--- /dev/null
+++ b/remove-os.patch
@@ -0,0 +1,46 @@
+diff --git a/gnatcoll.gpr b/gnatcoll.gpr
+index e0abbea3..b5024068 100644
+--- a/gnatcoll.gpr
++++ b/gnatcoll.gpr
+@@ -44,13 +44,6 @@ project GnatColl is
+
+ Sources := ("src", "src/os", "src/paragraph_filling");
+
+- case OS is
+- when "unix" | "osx" =>
+- Sources := Sources & ("src/os/unix");
+- when "windows" =>
+- Sources := Sources & ("src/os/win32");
+- end case;
+-
+ for Source_Dirs use Sources;
+
+ for Library_Kind use Library_Type;
+@@ -169,9 +162,6 @@ project GnatColl is
+
+ package Naming is
+
+- for Specification ("GNATCOLL.OS.Constants")
+- use "gnatcoll-os-constants__" & OS & ".ads";
+-
+ case OS is
+ when "unix" | "osx" =>
+ for Specification ("GNATCOLL.Mmap.System")
+@@ -182,8 +172,6 @@ project GnatColl is
+ use "gnatcoll-io-native-codec__unix.adb";
+ for Implementation ("GNATCOLL.Plugins")
+ use "gnatcoll-plugins__unix.adb";
+- for Implementation ("GNATCOLL.OS.Stat.Stat")
+- use "gnatcoll-os-stat-stat__unix.adb";
+ when "windows" =>
+ for Specification ("GNATCOLL.Mmap.System")
+ use "gnatcoll-mmap-system__win32.ads";
+@@ -193,8 +181,6 @@ project GnatColl is
+ use "gnatcoll-io-native-codec__win32.adb";
+ for Implementation ("GNATCOLL.Plugins")
+ use "gnatcoll-plugins__windows.adb";
+- for Implementation ("GNATCOLL.OS.Stat.Stat")
+- use "gnatcoll-os-stat-stat__win32.adb";
+ end case;
+
+ end Naming;