summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--gnatcoll_python.gpr-patch11
-rw-r--r--setup.py-patch11
4 files changed, 37 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6d6e52cda5a..d02de1a01694 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = gnatcoll-python
pkgdesc = GNAT Components Collection - interface to the python interpreter.
- pkgver = 2018
- pkgrel = 2
+ pkgver = 2020
+ pkgrel = 1
url = https://github.com/AdaCore/gnatcoll-bindings/
arch = i686
arch = x86_64
license = GPL
- makedepends = gprbuild>=2018
+ makedepends = gprbuild
depends = python2
- depends = gnatcoll-core>=2018
- source = http://mirrors.cdn.adacore.com/art/5b0ce9cfc7a4475261f97ca5
- source = setup.py-patch
- sha1sums = 42682c885e4a02bb03786aa9ece3a4214ca419f8
- sha1sums = 92d80368c81b0e9eef3f9ab7e0fcc5da61b532e9
+ depends = gnatcoll-core
+ source = https://community.download.adacore.com/v1/3c54db553121bf88877e2f56ac4fca36765186eb?filename=$bindings_src.tar.gz
+ source = gnatcoll_python.gpr-patch
+ sha1sums = 3c54db553121bf88877e2f56ac4fca36765186eb
+ sha1sums = 2cdbc553ec055f023f127117e4481266bbfcfe30
pkgname = gnatcoll-python
diff --git a/PKGBUILD b/PKGBUILD
index 444cd79029ed..682967c1f912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,41 @@
# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
pkgname=gnatcoll-python
-pkgver=2018
-pkgrel=2
+pkgver=2020
+pkgrel=1
pkgdesc='GNAT Components Collection - interface to the python interpreter.'
url='https://github.com/AdaCore/gnatcoll-bindings/'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('python2' 'gnatcoll-core>=2018')
-makedepends=('gprbuild>=2018')
+depends=('python2' 'gnatcoll-core')
+makedepends=('gprbuild')
-source=('http://mirrors.cdn.adacore.com/art/5b0ce9cfc7a4475261f97ca5'
- 'setup.py-patch')
-sha1sums=('42682c885e4a02bb03786aa9ece3a4214ca419f8'
- '92d80368c81b0e9eef3f9ab7e0fcc5da61b532e9')
+bindings_src=gnatcoll-bindings-20.0-20191009-1B2EA-src
+
+source=('https://community.download.adacore.com/v1/3c54db553121bf88877e2f56ac4fca36765186eb?filename=$bindings_src.tar.gz'
+ 'gnatcoll_python.gpr-patch')
+
+sha1sums=('3c54db553121bf88877e2f56ac4fca36765186eb'
+ '2cdbc553ec055f023f127117e4481266bbfcfe30')
prepare()
{
- cd "$srcdir/gnatcoll-bindings-gpl-2018-src/python"
- patch -Np0 -i "$srcdir"/setup.py-patch
+ cd "$srcdir/$bindings_src/python"
+ patch -Np0 -i "$srcdir"/gnatcoll_python.gpr-patch
}
+
build()
{
- cd "$srcdir/gnatcoll-bindings-gpl-2018-src/python"
- python2 setup.py build -j1 --prefix=/usr -R
+ cd "$srcdir/$bindings_src/python"
+ python2 setup.py build -j1 --prefix=/usr
}
+
package()
{
- cd "$srcdir/gnatcoll-bindings-gpl-2018-src/python"
+ cd "$srcdir/$bindings_src/python"
python2 setup.py install --prefix="$pkgdir/usr"
}
diff --git a/gnatcoll_python.gpr-patch b/gnatcoll_python.gpr-patch
new file mode 100644
index 000000000000..ae6a07e24063
--- /dev/null
+++ b/gnatcoll_python.gpr-patch
@@ -0,0 +1,11 @@
+--- gnatcoll_python.gpr 2020-05-27 08:29:56.584766613 +1000
++++ gnatcoll_python.gpr-new 2020-05-27 08:30:14.718689892 +1000
+@@ -73,7 +73,7 @@
+ when "PROD" =>
+ -- Do not use -gnatwe for production mode
+ for Switches ("Ada") use ("-O2", "-gnatn", "-gnatwaCJ");
+- for Switches ("C") use ("-O2", "-Wunreachable-code") & Split(Python_CFLAGS, " ");
++ for Switches ("C") use ("-O2", "-Wunreachable-code", "-fPIC") & Split(Python_CFLAGS, " ");
+ end case;
+ end Compiler;
+
diff --git a/setup.py-patch b/setup.py-patch
deleted file mode 100644
index 7e54684c0d59..000000000000
--- a/setup.py-patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py 2018-08-29 01:02:26.566772927 +1000
-+++ setup.py-new 2018-08-29 01:03:18.566772928 +1000
-@@ -82,7 +82,7 @@
- # On Linux platform, even when linking with the static libpython,
- # symbols not used by the application itself should be exported so
- # that shared library present in Python can use the Python C API.
-- python_static_libs += ' -export-dynamic'
-+ python_static_libs = ' -export-dynamic'
- python_shared_libs += ' -export-dynamic'
-
- logging.info(' %-24s %s', 'Shared linker flags', python_shared_libs)