summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--setup.py-patch11
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57345fb7928e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gnatcoll-python
+ pkgdesc = GNAT Components Collection - interface to the python interpreter.
+ pkgver = 2018
+ pkgrel = 1
+ url = https://github.com/AdaCore/gnatcoll-bindings/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gprbuild
+ depends = gcc-ada
+ depends = python2
+ depends = gnatcoll-core
+ provides = gnatcoll-python
+ conflicts = gnatcoll-python
+ source = http://mirrors.cdn.adacore.com/art/5b0ce9cfc7a4475261f97ca5
+ source = setup.py-patch
+ sha1sums = 42682c885e4a02bb03786aa9ece3a4214ca419f8
+ sha1sums = 92d80368c81b0e9eef3f9ab7e0fcc5da61b532e9
+
+pkgname = gnatcoll-python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..175d43022548
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
+
+pkgname=gnatcoll-python
+pkgver=2018
+pkgrel=1
+
+pkgdesc='GNAT Components Collection - interface to the python interpreter.'
+url='https://github.com/AdaCore/gnatcoll-bindings/'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+depends=('gcc-ada' 'python2' 'gnatcoll-core')
+makedepends=('gprbuild')
+
+provides=('gnatcoll-python')
+conflicts=('gnatcoll-python')
+
+source=('http://mirrors.cdn.adacore.com/art/5b0ce9cfc7a4475261f97ca5'
+ 'setup.py-patch')
+sha1sums=('42682c885e4a02bb03786aa9ece3a4214ca419f8'
+ '92d80368c81b0e9eef3f9ab7e0fcc5da61b532e9')
+
+
+prepare()
+{
+ cd "$srcdir/gnatcoll-bindings-gpl-2018-src/python"
+ patch -Np0 -i "$srcdir"/setup.py-patch
+}
+
+build()
+{
+ cd "$srcdir/gnatcoll-bindings-gpl-2018-src/python"
+ python2 setup.py build -j$(nproc) --prefix=/usr -R
+}
+
+package()
+{
+ cd "$srcdir/gnatcoll-bindings-gpl-2018-src/python"
+ python2 setup.py install --prefix="$pkgdir/usr"
+}
diff --git a/setup.py-patch b/setup.py-patch
new file mode 100644
index 000000000000..7e54684c0d59
--- /dev/null
+++ b/setup.py-patch
@@ -0,0 +1,11 @@
+--- setup.py 2018-08-29 01:02:26.566772927 +1000
++++ setup.py-new 2018-08-29 01:03:18.566772928 +1000
+@@ -82,7 +82,7 @@
+ # On Linux platform, even when linking with the static libpython,
+ # symbols not used by the application itself should be exported so
+ # that shared library present in Python can use the Python C API.
+- python_static_libs += ' -export-dynamic'
++ python_static_libs = ' -export-dynamic'
+ python_shared_libs += ' -export-dynamic'
+
+ logging.info(' %-24s %s', 'Shared linker flags', python_shared_libs)