summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 619d1ec0c3a6..2a61e3197a28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnaural
pkgdesc = An opensource binaural-beat generator
pkgver = 1.0.20110606
- pkgrel = 2
+ pkgrel = 3
url = http://gnaural.sourceforge.net/
install = gnaural.install
arch = i686
@@ -9,9 +9,6 @@ pkgbase = gnaural
license = GPL
depends = libglade
depends = portaudio
- conflicts = gnaural2
- conflicts = gnaural-cvs
- conflicts = gnaural-bbgen
source = http://downloads.sourceforge.net/project/gnaural/Gnaural/gnaural-1.0.20110606.tar.gz
md5sums = 8eea03a78ba02ee5d13c55fc6c0c9a00
diff --git a/PKGBUILD b/PKGBUILD
index f67ffeb42294..3c8726c2554d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
-# Maintainer: SpepS <dreamspepser at yahoo dot it>
+# Maintainer: dustball <sebastiansonne at hush dot com>
pkgname=gnaural
pkgver=1.0.20110606
-pkgrel=2
+pkgrel=3
pkgdesc="An opensource binaural-beat generator"
arch=(i686 x86_64)
url="http://gnaural.sourceforge.net/"
license=('GPL')
depends=('libglade' 'portaudio')
-conflicts=('gnaural2' 'gnaural-cvs' 'gnaural-bbgen')
install="$pkgname.install"
source=("http://downloads.sourceforge.net/project/$pkgname/Gnaural/$pkgname-$pkgver.tar.gz")
md5sums=('8eea03a78ba02ee5d13c55fc6c0c9a00')
@@ -16,6 +15,10 @@ md5sums=('8eea03a78ba02ee5d13c55fc6c0c9a00')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # Fix a bug where an inlined function isn't marked as extern. GCC seems to have tolerated rather long, but eventually broke.
+ sed -i 's/#endif/extern inline void BB_ResetAllVoices ();\n#endif/g' src/main.h src/gnauralXML.h
+ sed -i 's/^inline void BB_ResetAllVoices/void BB_ResetAllVoices/g' src/BinauralBeat.c
+
# desktop file path fix
sed -i "s|gnome/apps/Multimedia|applications|g" Makefile.*