summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD52
-rw-r--r--add_cinnamon_settings_online_support.patch13
-rw-r--r--replace_link_cinnamon_settings_online_support.patch13
-rw-r--r--set_window_icon_name.patch11
5 files changed, 19 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57290c3d6034..60b05f5372cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,26 @@
pkgbase = gnome-calendar-linuxmint
- pkgdesc = Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches
- pkgver = 3.34.2
- pkgrel = 2
- url = https://wiki.gnome.org/Apps/Calendar
+ pkgdesc = Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. (Package from Linux Mint repos)
+ pkgver = 41.2
+ pkgrel = 1
+ url = http://packages.linuxmint.com/pool/upstream/g/gnome-calendar
arch = x86_64
groups = gnome
license = GPL
makedepends = appstream-glib
makedepends = git
makedepends = meson
- makedepends = python
- depends = cinnamon
- depends = cinnamon-control-center
depends = evolution-data-server
- depends = geoclue2
+ depends = geoclue
depends = gnome-online-accounts
depends = gsettings-desktop-schemas
depends = libdazzle
depends = libgweather
+ depends = libhandy
depends = libical
optdepends = evolution: ICS file import
provides = gnome-calendar
conflicts = gnome-calendar
- source = git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=98881b9071ce39b8704e9b5af4eb1faa064ba3fa
- source = add_cinnamon_settings_online_support.patch
- source = replace_link_cinnamon_settings_online_support.patch
- source = set_window_icon_name.patch
- sha256sums = SKIP
- sha256sums = c05b6d35b89c9b121d544f86a788f021bf06a705d8c507c8a9eecc596d1320ba
- sha256sums = ee49aad54bee8c50e5cdbbe68cd6f58287cd1cb368dd0f9f3a996a99418489c4
- sha256sums = 1788c8cb1fbf8bd5cf81d700d9f5f7eb1e5eea265e35930dc70df147f79ebc9a
+ source = gnome-calendar-linuxmint_41.2.tar.xz::http://packages.linuxmint.com/pool/upstream/g/gnome-calendar/gnome-calendar_41.2+mint1+vanessa.tar.xz
+ sha256sums = ebd29c6b19ccc370e4b024247ab9aa925766a7782ddda8076076964c89ffb06f
pkgname = gnome-calendar-linuxmint
-
diff --git a/PKGBUILD b/PKGBUILD
index fee6612750b6..c56f01cf857c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname=gnome-calendar-linuxmint
_pkgname=gnome-calendar
-pkgver=3.34.2
-pkgrel=2
-pkgdesc='Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches'
+pkgver=41.2
+_pkgver=mint1+vanessa
+pkgrel=1
+pkgdesc='Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. (Package from Linux Mint repos)'
arch=(x86_64)
-url=https://wiki.gnome.org/Apps/Calendar
+url="http://packages.linuxmint.com/pool/upstream/g/${_pkgname}"
license=(GPL)
depends=(
- cinnamon
- cinnamon-control-center
evolution-data-server
- geoclue2
+ geoclue
gnome-online-accounts
gsettings-desktop-schemas
libdazzle
libgweather
+ libhandy
libical
)
optdepends=(
@@ -26,50 +26,20 @@ makedepends=(
appstream-glib
git
meson
- python
)
provides=(${_pkgname})
conflicts=(${_pkgname})
groups=(gnome)
-_commit=98881b9071ce39b8704e9b5af4eb1faa064ba3fa # tags/3.34.2^0
-source=(
- "git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit"
- "add_cinnamon_settings_online_support.patch"
- "replace_link_cinnamon_settings_online_support.patch"
- "set_window_icon_name.patch"
-)
-sha256sums=('SKIP'
- 'c05b6d35b89c9b121d544f86a788f021bf06a705d8c507c8a9eecc596d1320ba'
- 'ee49aad54bee8c50e5cdbbe68cd6f58287cd1cb368dd0f9f3a996a99418489c4'
- '1788c8cb1fbf8bd5cf81d700d9f5f7eb1e5eea265e35930dc70df147f79ebc9a')
-
-pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/-/+/g'
-}
-
-prepare() {
- cd $_pkgname
-
- # Fix: Set window icon name
- patch -Np0 -i ../set_window_icon_name.patch
+source=("${pkgname}_${pkgver}.tar.xz::${url}/${_pkgname}_${pkgver}+${_pkgver}.tar.xz")
+sha256sums=('ebd29c6b19ccc370e4b024247ab9aa925766a7782ddda8076076964c89ffb06f')
+
- # Replace GNOME Control Center internal call with Cinnamon Settings (cinnamon-settings online-accounts)
- patch -Np0 -i ../add_cinnamon_settings_online_support.patch
-
- # Replace GNOME Web Description link label with cinnamon-settings online-accounts
- patch -Np0 -i ../replace_link_cinnamon_settings_online_support.patch
-}
build() {
arch-meson $_pkgname build
ninja -C build
}
-check() {
- meson test -C build --print-errorlogs
-}
-
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}
diff --git a/add_cinnamon_settings_online_support.patch b/add_cinnamon_settings_online_support.patch
deleted file mode 100644
index c859a3b010fb..000000000000
--- a/add_cinnamon_settings_online_support.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/gui/gcal-window.c
-+++ src/gui/gcal-window.c
-@@ -395,7 +395,7 @@
- {
- GApplication *application = g_application_get_default ();
-
-- gcal_utils_launch_online_accounts_panel (g_application_get_dbus_connection (application), NULL, NULL);
-+ g_spawn_command_line_async ("cinnamon-settings online-accounts", NULL);
- }
-
- static void
-
-
diff --git a/replace_link_cinnamon_settings_online_support.patch b/replace_link_cinnamon_settings_online_support.patch
deleted file mode 100644
index 2d2d8ff87d27..000000000000
--- a/replace_link_cinnamon_settings_online_support.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/gui/calendar-management/gcal-new-calendar-page.c
-+++ src/gui/calendar-management/gcal-new-calendar-page.c
-@@ -471,7 +471,7 @@
- {
- GDBusConnection *connection = g_application_get_dbus_connection (g_application_get_default ());
-
-- gcal_utils_launch_online_accounts_panel (connection, NULL, NULL);
-+ g_spawn_command_line_async ("cinnamon-settings online-accounts", NULL);
- }
-
-
-
-
diff --git a/set_window_icon_name.patch b/set_window_icon_name.patch
deleted file mode 100644
index 03e2b4b99dea..000000000000
--- a/set_window_icon_name.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gui/gcal-window.c
-+++ src/gui/gcal-window.c
-@@ -1131,6 +1131,8 @@
- gcal_window_add_accelerator (app, "win.change-view(3)", "<Ctrl>3");
- gcal_window_add_accelerator (app, "app.quit", "<Ctrl>q");
- gcal_window_add_accelerator (app, "win.new-event", "<Ctrl>n");
-+
-+ gtk_window_set_icon_name (self, "org.gnome.Calendar");
- }
-
- /**