summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--add_cinnamon_settings_online_support.patch23
-rw-r--r--null-icaltime.diff14
-rw-r--r--replace_link_cinnamon_settings_online_support.patch13
5 files changed, 37 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d6f19f99513..57290c3d6034 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,22 +8,27 @@ pkgbase = gnome-calendar-linuxmint
license = GPL
makedepends = appstream-glib
makedepends = git
- makedepends = gnome-control-center
makedepends = meson
makedepends = python
+ depends = cinnamon
+ depends = cinnamon-control-center
depends = evolution-data-server
depends = geoclue2
+ depends = gnome-online-accounts
depends = gsettings-desktop-schemas
depends = libdazzle
depends = libgweather
+ depends = libical
optdepends = evolution: ICS file import
provides = gnome-calendar
conflicts = gnome-calendar
source = git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=98881b9071ce39b8704e9b5af4eb1faa064ba3fa
source = add_cinnamon_settings_online_support.patch
+ source = replace_link_cinnamon_settings_online_support.patch
source = set_window_icon_name.patch
sha256sums = SKIP
- sha256sums = 9b81f538a4ebc74c66b6ea80a02303fe6adfc92dc183e6a96e0f090ac777e7d9
+ sha256sums = c05b6d35b89c9b121d544f86a788f021bf06a705d8c507c8a9eecc596d1320ba
+ sha256sums = ee49aad54bee8c50e5cdbbe68cd6f58287cd1cb368dd0f9f3a996a99418489c4
sha256sums = 1788c8cb1fbf8bd5cf81d700d9f5f7eb1e5eea265e35930dc70df147f79ebc9a
pkgname = gnome-calendar-linuxmint
diff --git a/PKGBUILD b/PKGBUILD
index 8504332e2f86..fee6612750b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,11 +9,15 @@ arch=(x86_64)
url=https://wiki.gnome.org/Apps/Calendar
license=(GPL)
depends=(
+ cinnamon
+ cinnamon-control-center
evolution-data-server
geoclue2
+ gnome-online-accounts
gsettings-desktop-schemas
libdazzle
libgweather
+ libical
)
optdepends=(
'evolution: ICS file import'
@@ -21,7 +25,6 @@ optdepends=(
makedepends=(
appstream-glib
git
- gnome-control-center
meson
python
)
@@ -32,10 +35,12 @@ _commit=98881b9071ce39b8704e9b5af4eb1faa064ba3fa # tags/3.34.2^0
source=(
"git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit"
"add_cinnamon_settings_online_support.patch"
+ "replace_link_cinnamon_settings_online_support.patch"
"set_window_icon_name.patch"
)
sha256sums=('SKIP'
- '9b81f538a4ebc74c66b6ea80a02303fe6adfc92dc183e6a96e0f090ac777e7d9'
+ 'c05b6d35b89c9b121d544f86a788f021bf06a705d8c507c8a9eecc596d1320ba'
+ 'ee49aad54bee8c50e5cdbbe68cd6f58287cd1cb368dd0f9f3a996a99418489c4'
'1788c8cb1fbf8bd5cf81d700d9f5f7eb1e5eea265e35930dc70df147f79ebc9a')
pkgver() {
@@ -46,11 +51,14 @@ pkgver() {
prepare() {
cd $_pkgname
- # Add support so that gnome-calendar run within Cinnamon by calling cinnamon-settings online-accounts
- patch -Np0 -i ../add_cinnamon_settings_online_support.patch
-
# Fix: Set window icon name
patch -Np0 -i ../set_window_icon_name.patch
+
+ # Replace GNOME Control Center internal call with Cinnamon Settings (cinnamon-settings online-accounts)
+ patch -Np0 -i ../add_cinnamon_settings_online_support.patch
+
+ # Replace GNOME Web Description link label with cinnamon-settings online-accounts
+ patch -Np0 -i ../replace_link_cinnamon_settings_online_support.patch
}
build() {
diff --git a/add_cinnamon_settings_online_support.patch b/add_cinnamon_settings_online_support.patch
index 0c44aaf7944e..c859a3b010fb 100644
--- a/add_cinnamon_settings_online_support.patch
+++ b/add_cinnamon_settings_online_support.patch
@@ -1,28 +1,13 @@
--- src/gui/gcal-window.c
+++ src/gui/gcal-window.c
-@@ -394,8 +394,22 @@
- gpointer user_data)
+@@ -395,7 +395,7 @@
{
GApplication *application = g_application_get_default ();
--
+
- gcal_utils_launch_online_accounts_panel (g_application_get_dbus_connection (application), NULL, NULL);
-+ gchar *desktop_environment;
-+
-+ desktop_environment = getenv ("XDG_CURRENT_DESKTOP");
-+ if (desktop_environment)
-+ {
-+ if (g_strcmp0 (desktop_environment, "X-Cinnamon") == 0 || g_strcmp0 (desktop_environment, "Cinnamon") == 0)
-+ {
-++ g_spawn_command_line_async ("cinnamon-settings online-accounts", NULL);
-++ return;
-+ }
-+ else if (g_strcmp0 (desktop_environment, "GNOME") == 0)
-+ {
-+ gcal_utils_launch_online_accounts_panel (g_application_get_dbus_connection (application), NULL, NULL);
-+ }
-+ }
-+
++ g_spawn_command_line_async ("cinnamon-settings online-accounts", NULL);
}
static void
+
diff --git a/null-icaltime.diff b/null-icaltime.diff
deleted file mode 100644
index 60539d9bdb12..000000000000
--- a/null-icaltime.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git i/src/gcal-utils.c w/src/gcal-utils.c
-index c7646565..8070034c 100644
---- i/src/gcal-utils.c
-+++ w/src/gcal-utils.c
-@@ -181,6 +181,9 @@ icaltime_to_datetime (const icaltimetype *date)
- GDateTime *dt;
- GTimeZone *tz;
-
-+ if (!date)
-+ return NULL;
-+
- tz = date->zone ? g_time_zone_new (icaltime_get_tzid (*date)) : g_time_zone_new_utc ();
- dt = g_date_time_new (tz,
- date->year,
diff --git a/replace_link_cinnamon_settings_online_support.patch b/replace_link_cinnamon_settings_online_support.patch
new file mode 100644
index 000000000000..2d2d8ff87d27
--- /dev/null
+++ b/replace_link_cinnamon_settings_online_support.patch
@@ -0,0 +1,13 @@
+--- src/gui/calendar-management/gcal-new-calendar-page.c
++++ src/gui/calendar-management/gcal-new-calendar-page.c
+@@ -471,7 +471,7 @@
+ {
+ GDBusConnection *connection = g_application_get_dbus_connection (g_application_get_default ());
+
+- gcal_utils_launch_online_accounts_panel (connection, NULL, NULL);
++ g_spawn_command_line_async ("cinnamon-settings online-accounts", NULL);
+ }
+
+
+
+