summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 46 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5bc414416bf..9aae1aa2d100 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,30 @@
pkgbase = gnome-contacts-git
pkgdesc = Contacts Manager for GNOME
- pkgver = 3.36.r15.gb6cb216
+ pkgver = 44.0.r5.gdee5b4cc
pkgrel = 1
- url = https://wiki.gnome.org/Apps/Contacts
+ url = https://gitlab.gnome.org/GNOME/gnome-contacts
arch = i686
arch = x86_64
arch = armv7h
arch = aarch64
groups = gnome
license = GPL2
- makedepends = vala
- makedepends = gobject-introspection
+ makedepends = appstream-glib
makedepends = git
+ makedepends = gobject-introspection
makedepends = meson
- depends = gtk3
+ makedepends = vala
+ depends = evolution-data-server
depends = folks
- depends = gnome-desktop
- depends = dconf
depends = gnome-online-accounts
+ depends = gtk4
+ depends = libadwaita
depends = libgee
- depends = cheese
- depends = libhandy
+ depends = libportal-gtk4
+ depends = qrencode
provides = gnome-contacts
conflicts = gnome-contacts
- source = git+https://gitlab.gnome.org/GNOME/gnome-contacts.git
+ source = gnome-contacts::git+https://gitlab.gnome.org/GNOME/gnome-contacts
sha256sums = SKIP
pkgname = gnome-contacts-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 83c707088718..f61ea57abfa5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,48 @@
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
-pkgname=gnome-contacts-git
-pkgver=3.36.r15.gb6cb216
+_pkgname="gnome-contacts"
+pkgname="$_pkgname-git"
+pkgver=44.0.r5.gdee5b4cc
pkgrel=1
pkgdesc="Contacts Manager for GNOME"
-url="https://wiki.gnome.org/Apps/Contacts"
+# https://wiki.gnome.org/Apps/Contacts
+url="https://gitlab.gnome.org/GNOME/gnome-contacts"
arch=(i686 x86_64 armv7h aarch64)
license=(GPL2)
-depends=(gtk3 folks gnome-desktop dconf gnome-online-accounts libgee cheese libhandy)
-makedepends=(vala gobject-introspection git meson)
+depends=(
+ evolution-data-server
+ folks
+ gnome-online-accounts
+ gtk4
+ libadwaita
+ libgee
+ libportal-gtk4
+ qrencode
+)
+makedepends=(
+ appstream-glib
+ git
+ gobject-introspection
+ meson
+ vala
+)
groups=(gnome)
-conflicts=(gnome-contacts)
-provides=(gnome-contacts)
-source=("git+https://gitlab.gnome.org/GNOME/gnome-contacts.git")
+provides=("$_pkgname")
+conflicts=(${provides[@]})
+source=(
+ "$_pkgname"::"git+$url"
+)
sha256sums=('SKIP')
pkgver() {
- cd gnome-contacts
+ cd "$srcdir/$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson gnome-contacts build -D docs=true
- ninja -C build
+ arch-meson "$srcdir/$_pkgname" build
+ meson compile -C build
}
check() {
@@ -32,5 +51,5 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
}