summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..644ebc3a5966
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = gnome-dictionary-git
+ pkgdesc = Look up words in dictionary sources
+ pkgver = 3.26.1+94+g6d7f21e
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Dictionary
+ arch = x86_64
+ license = GPL2
+ makedepends = itstool
+ makedepends = docbook-xsl
+ makedepends = gtk-doc
+ makedepends = yelp-tools
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = appstream-glib
+ depends = dconf
+ depends = gtk3
+ provides = gnome-dictionary
+ conflicts = gnome-dictionary
+ source = git+https://gitlab.gnome.org/GNOME/gnome-dictionary.git
+ sha512sums = SKIP
+
+pkgname = gnome-dictionary-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c3dc5d9c4d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=gnome-dictionary-git
+_pkgname=gnome-dictionary
+pkgver=3.26.1+94+g6d7f21e
+pkgrel=1
+pkgdesc="Look up words in dictionary sources"
+url="https://wiki.gnome.org/Apps/Dictionary"
+arch=(x86_64)
+license=(GPL2)
+depends=('dconf' 'gtk3')
+makedepends=('itstool' 'docbook-xsl' 'gtk-doc' 'yelp-tools' 'git' 'gobject-introspection' 'meson' 'appstream-glib')
+provides=('gnome-dictionary')
+conflicts=('gnome-dictionary')
+source=("git+https://gitlab.gnome.org/GNOME/gnome-dictionary.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+}
+
+build() {
+ arch-meson $_pkgname build
+ ninja -C build
+}
+
+check() {
+ cd build
+ meson test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+# vim:set ts=2 sw=2 et: