summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a22cfe104152..072e3e70836b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-games-libretro
pkgdesc = Libretro definitions for gnome-games
pkgver = 3.30.0
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.gnome.org/Apps/Games
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index ccb3912fe59b..6691277691ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gnome-games-libretro
_srcname=gnome-games
pkgver=3.30.0
-pkgrel=1
+pkgrel=2
pkgdesc='Libretro definitions for gnome-games'
arch=('any')
license=('GPL3')
@@ -16,4 +16,11 @@ package() {
cd "$_srcname"
install -d "$pkgdir"/usr/lib/libretro/
install -t "$pkgdir"/usr/lib/libretro/ flatpak/libretro-cores/*.libretro
+
+ # bsnes-mercury is available on the AUR, but doesn't build at the moment.
+ # In general it's nice to provide the standard package as an option.
+ cp "$pkgdir"/usr/lib/libretro/bsnes_mercury_balanced.libretro \
+ "$pkgdir"/usr/lib/libretro/bsnes_balanced.libretro
+ sed -i 's/bsnes-mercury/bsnes/;s/bsnes_mercury/bsnes/' \
+ "$pkgdir"/usr/lib/libretro/bsnes_balanced.libretro
}