summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD70
1 files changed, 49 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0425ee789a3..dc434173c706 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,77 @@
# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
# Maintainer: Truocolo <truocolo@aol.com>
-pkgname=gnome-keyring-git
_pkgname=gnome-keyring
+pkgname="${_pkgname}-git"
pkgver=3.36.0+12+g4f531000
pkgrel=1
epoch=1
pkgdesc="Stores passwords and encryption keys"
url="https://wiki.gnome.org/Projects/GnomeKeyring"
arch=(x86_64)
-license=(GPL LGPL)
-depends=('gcr' 'libcap-ng' 'pam' 'openssh')
-makedepends=('git' 'docbook-xsl' 'python')
-provides=('gnome-keyring' 'org.freedesktop.secrets')
-conflicts=('gnome-keyring')
-groups=('gnome')
-install=gnome-keyring.install
-source=("git+https://gitlab.gnome.org/GNOME/gnome-keyring.git"
- 33.patch
- add-cinnamon.diff)
-sha256sums=('SKIP'
- '23294d6569bb7c8297cc2f95071576fac48ee82ec1ead1b818dd69fbbc72b069'
- 'd05210f5b0a7d4b22c0dff2854854af2eb5708aa2b296095e070dca68e9f815a')
+license=(
+ GPL
+ LGPL)
+depends=(
+ 'gcr-4'
+ 'libcap-ng'
+ 'pam'
+ 'openssh')
+makedepends=(
+ 'git'
+ 'docbook-xsl'
+ 'python'
+)
+provides=(
+ 'gnome-keyring'
+ 'org.freedesktop.secrets')
+conflicts=(
+ 'gnome-keyring')
+groups=(
+ 'gnome')
+install="${_pkgname}.install"
+source=(
+ "git+https://gitlab.gnome.org/GNOME/gnome-keyring.git"
+ 33.patch
+ add-cinnamon.diff)
+sha256sums=(
+ 'SKIP'
+ '23294d6569bb7c8297cc2f95071576fac48ee82ec1ead1b818dd69fbbc72b069'
+ 'd05210f5b0a7d4b22c0dff2854854af2eb5708aa2b296095e070dca68e9f815a')
pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/-/+/g'
+ cd \
+ "${_pkgname}"
+ git \
+ describe \
+ --tags | \
+ sed \
+ 's/-/+/g'
}
prepare() {
- cd $_pkgname
+ cd "${_pkgname}"
# https://bugs.archlinux.org/task/68664
# https://gitlab.gnome.org/GNOME/gnome-keyring/-/merge_requests/33
- git apply -3 ../33.patch
+ git \
+ apply \
+ -3 ../33.patch
# Autolaunch in Cinnamon
- git apply -3 ../add-cinnamon.diff
+ git \
+ apply \
+ -3 \
+ ../add-cinnamon.diff
- NOCONFIGURE=1 ./autogen.sh
+ NOCONFIGURE=1 \
+ ./autogen.sh
}
build() {
cd $_pkgname
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--libexecdir=/usr/lib \