summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--gnome-mpv.install1
-rw-r--r--remove-inline.patch152
4 files changed, 9 insertions, 173 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d225103f2b55..b5d856ae3391 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-mpv
pkgdesc = GNOME frontend for MPV
- pkgver = 0.4
- pkgrel = 2
+ pkgver = 0.5
+ pkgrel = 1
url = https://github.com/gnome-mpv/gnome-mpv
install = gnome-mpv.install
arch = i686
@@ -11,12 +11,8 @@ pkgbase = gnome-mpv
depends = gtk3
depends = mpv
conflicts = gnome-mpv-git
- source = https://github.com/gnome-mpv/gnome-mpv/archive/v0.4.tar.gz
- source = gnome-mpv.install
- source = remove-inline.patch
- sha256sums = 3b72cc9c070d6e5efd4390b1ab333b50e7f4da380452169a40754be4128d4ffc
- sha256sums = 2f53c431d6a6ed51b5abe0f42f90bdcd9c1cc7776962e8f8bc0d77a95e114f51
- sha256sums = 59f5475a40b3eaa68bb6ea6955b219ee148f8301337caf3fbfe6e7dd3958b0ff
+ source = https://github.com/gnome-mpv/gnome-mpv/archive/v0.5.tar.gz
+ sha256sums = 56064c16fb9a8b4e79cdd338800dd989588bed11574e4993a36308707e304cf3
pkgname = gnome-mpv
diff --git a/PKGBUILD b/PKGBUILD
index e6509258d1d3..b5bd4a9edfed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Ainola
pkgname=gnome-mpv
-pkgver=0.4
-pkgrel=2
+pkgver=0.5
+pkgrel=1
pkgdesc="GNOME frontend for MPV"
arch=('i686' 'x86_64')
url="https://github.com/gnome-mpv/gnome-mpv"
@@ -10,19 +10,10 @@ license=('GPL3')
depends=('gtk3' 'mpv')
makedepends=('intltool')
conflicts=('gnome-mpv-git')
-source=("https://github.com/gnome-mpv/gnome-mpv/archive/v${pkgver}.tar.gz"
- "${pkgname}.install"
- "remove-inline.patch")
-sha256sums=('3b72cc9c070d6e5efd4390b1ab333b50e7f4da380452169a40754be4128d4ffc'
- '2f53c431d6a6ed51b5abe0f42f90bdcd9c1cc7776962e8f8bc0d77a95e114f51'
- '59f5475a40b3eaa68bb6ea6955b219ee148f8301337caf3fbfe6e7dd3958b0ff')
+source=("https://github.com/gnome-mpv/gnome-mpv/archive/v${pkgver}.tar.gz")
+sha256sums=('56064c16fb9a8b4e79cdd338800dd989588bed11574e4993a36308707e304cf3')
install=('gnome-mpv.install')
-prepare() {
- # Fix issue #27 (https://github.com/gnome-mpv/gnome-mpv/issues/27) until next release.
- patch -p0 < remove-inline.patch
-}
-
build() {
cd "${pkgname}-${pkgver}"
autoreconf -sfi
diff --git a/gnome-mpv.install b/gnome-mpv.install
index c317fbaca442..e148c50d80eb 100644
--- a/gnome-mpv.install
+++ b/gnome-mpv.install
@@ -1,4 +1,5 @@
post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
}
diff --git a/remove-inline.patch b/remove-inline.patch
deleted file mode 100644
index b5cef0b2d547..000000000000
--- a/remove-inline.patch
+++ /dev/null
@@ -1,152 +0,0 @@
-*** gnome-mpv-0.4/src/common.c 2015-05-30 15:01:05.199253876 -0600
---- gnome-mpv-0.4/src/common.c 2015-05-30 15:01:05.199253876 -0600
-***************
-*** 28,41 ****
- #include "control_box.h"
- #include "playlist_widget.h"
-
-! inline gchar *get_config_string( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key )
- {
- return g_key_file_get_string(ctx->config_file, group, key, NULL);
- }
-
-! inline void set_config_string( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- const gchar *value)
---- 28,41 ----
- #include "control_box.h"
- #include "playlist_widget.h"
-
-! gchar *get_config_string( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key )
- {
- return g_key_file_get_string(ctx->config_file, group, key, NULL);
- }
-
-! void set_config_string( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- const gchar *value)
-***************
-*** 44,50 ****
- g_key_file_set_string(ctx->config_file, group, key, value?value:"");
- }
-
-! inline gboolean get_config_boolean( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- gboolean defaultval )
---- 44,50 ----
- g_key_file_set_string(ctx->config_file, group, key, value?value:"");
- }
-
-! gboolean get_config_boolean( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- gboolean defaultval )
-***************
-*** 60,66 ****
- return !keyfile_error?result:defaultval;
- }
-
-! inline void set_config_boolean( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- gboolean value)
---- 60,66 ----
- return !keyfile_error?result:defaultval;
- }
-
-! void set_config_boolean( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- gboolean value)
-***************
-*** 68,74 ****
- g_key_file_set_boolean(ctx->config_file, group, key, value);
- }
-
-! inline gchar *get_config_dir_path(void)
- {
- return g_strconcat( g_get_user_config_dir(),
- "/",
---- 68,74 ----
- g_key_file_set_boolean(ctx->config_file, group, key, value);
- }
-
-! gchar *get_config_dir_path(void)
- {
- return g_strconcat( g_get_user_config_dir(),
- "/",
-***************
-*** 76,82 ****
- NULL );
- }
-
-! inline gchar *get_config_file_path(void)
- {
- return g_strconcat( get_config_dir_path(),
- "/"
---- 76,82 ----
- NULL );
- }
-
-! gchar *get_config_file_path(void)
- {
- return g_strconcat( get_config_dir_path(),
- "/"
-*** gnome-mpv-0.4/src/common.h 2015-05-30 15:01:05.199253876 -0600
---- gnome-mpv-0.4/src/common.h 2015-05-30 15:01:05.199253876 -0600
-***************
-*** 47,69 ****
- GtkListStore *playlist_store;
- };
-
-! inline gchar *get_config_string( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key );
-! inline void set_config_string( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- const gchar *value );
-! inline gboolean get_config_boolean( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- gboolean defaultval );
-! inline void set_config_boolean( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- gboolean value);
-! inline gchar *get_config_dir_path(void);
-! inline gchar *get_config_file_path(void);
- gboolean load_config(gmpv_handle *ctx);
- gboolean save_config(gmpv_handle *ctx);
- gchar *get_path_from_uri(const gchar *uri);
---- 47,69 ----
- GtkListStore *playlist_store;
- };
-
-! gchar *get_config_string( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key );
-! void set_config_string( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- const gchar *value );
-! gboolean get_config_boolean( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- gboolean defaultval );
-! void set_config_boolean( gmpv_handle *ctx,
- const gchar *group,
- const gchar *key,
- gboolean value);
-! gchar *get_config_dir_path(void);
-! gchar *get_config_file_path(void);
- gboolean load_config(gmpv_handle *ctx);
- gboolean save_config(gmpv_handle *ctx);
- gchar *get_path_from_uri(const gchar *uri);