summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58a0da7400f9..112228121c24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,12 @@
pkgbase = gnome-music-git
pkgdesc = Music player and management application
- pkgver = 3.31.1.r63.gd2587147
+ pkgver = 3.36.0.r85.g4976f447
pkgrel = 1
url = https://wiki.gnome.org/Apps/Music
+ arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
groups = gnome
license = GPL
makedepends = gobject-introspection
@@ -16,7 +19,6 @@ pkgbase = gnome-music-git
depends = tracker-miners
depends = libdmapsharing
depends = libmediaart
- depends = gtk3
depends = gvfs
depends = python-gobject
depends = python-cairo
@@ -31,6 +33,8 @@ pkgbase = gnome-music-git
conflicts = gnome-music
source = git+https://gitlab.gnome.org/GNOME/gnome-music.git
source = git+https://gitlab.gnome.org/GNOME/libgd.git
+ source = git+https://gitlab.gnome.org/mschraal/gfm.git
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c1a74737cd2e..ceb9fb476d0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
# Contributor: emersion <contact@emersion.fr>
pkgname=gnome-music-git
-pkgver=3.31.1.r63.gd2587147
+pkgver=3.36.0.r85.g4976f447
pkgrel=1
pkgdesc="Music player and management application"
url="https://wiki.gnome.org/Apps/Music"
-arch=(x86_64)
+arch=(i686 x86_64 armv7h aarch64)
license=(GPL)
-depends=(grilo grilo-plugins tracker-miners libdmapsharing libmediaart gtk3 gvfs python-gobject
- python-cairo gst-plugins-base python-requests libdazzle)
+depends=(grilo grilo-plugins tracker-miners libdmapsharing libmediaart gvfs
+ python-gobject python-cairo gst-plugins-base python-requests libdazzle)
makedepends=(gobject-introspection git meson yelp-tools appstream-glib)
optdepends=('gst-plugins-good: Extra media codecs'
'gst-plugins-ugly: Extra media codecs'
@@ -22,8 +22,10 @@ conflicts=(gnome-music)
provides=(gnome-music)
groups=(gnome)
source=("git+https://gitlab.gnome.org/GNOME/gnome-music.git"
- "git+https://gitlab.gnome.org/GNOME/libgd.git")
+ "git+https://gitlab.gnome.org/GNOME/libgd.git"
+ "git+https://gitlab.gnome.org/mschraal/gfm.git")
sha256sums=('SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -35,7 +37,8 @@ prepare() {
cd gnome-music
git submodule init
- git config --local submodule.subprojects/libgd.url "$srcdir/libgd"
+ git submodule set-url subprojects/libgd "$srcdir/libgd"
+ git submodule set-url subprojects/gfm "$srcdir/gfm"
git submodule update
}
@@ -45,11 +48,11 @@ build() {
}
check() {
- meson test -C build
+ ninja -C build test
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ DESTDIR="$pkgdir" ninja -C build install
python -m compileall -d /usr/lib "$pkgdir/usr/lib"
python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"