summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--minimize.patch77
3 files changed, 17 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9048ed1d7adc..833f43bd3444 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-panel-minimal
pkgdesc = Panel of GNOME Flashback (minimal build)
pkgver = 3.44.0+0a5a7081f
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.gnome.org/Projects/GnomePanel
arch = x86_64
license = GPL
@@ -17,6 +17,6 @@ pkgbase = gnome-panel-minimal
source = git+https://gitlab.gnome.org/GNOME/gnome-panel.git#tag=3.44.0
source = minimize.patch
sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = 4b3cf4712ba64363f62185c3fead3fc7726bf4194f03260ae82bd8dfb95e58cc
pkgname = gnome-panel-minimal
diff --git a/PKGBUILD b/PKGBUILD
index c75f062fea6e..9a01852b4a3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname=gnome-panel
_pkgver=3.44.0
pkgname=${_pkgname}-minimal
pkgver=3.44.0+0a5a7081f
-pkgrel=2
+pkgrel=3
pkgdesc='Panel of GNOME Flashback (minimal build)'
arch=('x86_64')
url='https://wiki.gnome.org/Projects/GnomePanel'
@@ -17,7 +17,7 @@ conflicts=("${_pkgname}")
source=("git+https://gitlab.gnome.org/GNOME/gnome-panel.git#tag=${_pkgver}"
'minimize.patch')
sha256sums=('SKIP'
- 'SKIP')
+ '4b3cf4712ba64363f62185c3fead3fc7726bf4194f03260ae82bd8dfb95e58cc')
pkgver() {
cd "${srcdir}/${_pkgname}"
diff --git a/minimize.patch b/minimize.patch
index 4127a207715d..88a0a714dcc7 100644
--- a/minimize.patch
+++ b/minimize.patch
@@ -347,17 +347,17 @@ index 8c086344e..9bd400e46 100644
if ENABLE_DOCUMENTATION
SUBDIRS += $(DIST_SUBDIRS)
diff --git a/modules/Makefile.am b/modules/Makefile.am
-index ee1ae0bf6..ba69b7d58 100644
+index ee1ae0bf6..a488ae9aa 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
-@@ -1,14 +1,9 @@
+@@ -1,14 +1,8 @@
NULL =
SUBDIRS = \
- action-button \
- clock \
- fish \
- launcher \
+- launcher \
- menu \
notification-area \
separator \
@@ -365,59 +365,8 @@ index ee1ae0bf6..ba69b7d58 100644
wncklet \
$(NULL)
-diff --git a/modules/launcher/Makefile.am b/modules/launcher/Makefile.am
-index d336374c5..929ffcd1c 100644
---- a/modules/launcher/Makefile.am
-+++ b/modules/launcher/Makefile.am
-@@ -27,13 +27,8 @@ org_gnome_gnome_panel_launcher_la_SOURCES = \
- gp-editor.h \
- gp-icon-name-chooser.c \
- gp-icon-name-chooser.h \
-- gp-launcher-applet.c \
- gp-launcher-applet.h \
-- gp-launcher-button.c \
-- gp-launcher-button.h \
- gp-launcher-module.c \
-- gp-launcher-properties.c \
-- gp-launcher-properties.h \
- gp-launcher-utils.c \
- gp-launcher-utils.h \
- $(BUILT_SOURCES) \
-diff --git a/modules/launcher/gp-custom-launcher-applet.c b/modules/launcher/gp-custom-launcher-applet.c
-index d29724686..5fffbe2cc 100644
---- a/modules/launcher/gp-custom-launcher-applet.c
-+++ b/modules/launcher/gp-custom-launcher-applet.c
-@@ -34,7 +34,7 @@ struct _GpCustomLauncherApplet
-
- G_DEFINE_TYPE (GpCustomLauncherApplet,
- gp_custom_launcher_applet,
-- GP_TYPE_LAUNCHER_APPLET)
-+ GP_TYPE_CUSTOM_LAUNCHER_APPLET)
-
- static LauncherData *
- launcher_data_new (GpInitialSetupDialog *dialog)
-diff --git a/modules/launcher/gp-launcher-module.c b/modules/launcher/gp-launcher-module.c
-index 336918319..197951e1d 100644
---- a/modules/launcher/gp-launcher-module.c
-+++ b/modules/launcher/gp-launcher-module.c
-@@ -61,15 +61,6 @@ launcher_get_applet_info (const gchar *id)
- initial_setup_func = gp_custom_launcher_applet_initial_setup_dialog;
- is_disabled_func = custom_launcher_is_disabled;
- }
-- else if (g_strcmp0 (id, "launcher") == 0)
-- {
-- type_func = gp_launcher_applet_get_type;
-- name = _("Application Launcher...");
-- description = _("Copy a launcher from the applications menu");
-- icon = "gnome-panel-launcher";
--
-- initial_setup_func = gp_launcher_applet_initial_setup_dialog;
-- }
- else
- {
- g_assert_not_reached ();
diff --git a/po/POTFILES.in b/po/POTFILES.in
-index fd6cfd5cb..004cb4f9a 100644
+index fd6cfd5cb..b587dfa59 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1,7 +1,5 @@
@@ -428,7 +377,7 @@ index fd6cfd5cb..004cb4f9a 100644
data/org.gnome.gnome-panel.applet.window-list.gschema.xml
data/org.gnome.gnome-panel.applet.workspace-switcher.gschema.xml
data/org.gnome.gnome-panel.gschema.xml
-@@ -23,60 +21,22 @@ gnome-panel/panel-bindings.c
+@@ -23,60 +21,14 @@ gnome-panel/panel-bindings.c
gnome-panel/panel.c
gnome-panel/panel-context-menu.c
gnome-panel/panel-layout.c
@@ -460,16 +409,16 @@ index fd6cfd5cb..004cb4f9a 100644
-modules/fish/fish-module.c
-modules/fish/fish-menu.ui
-modules/fish/fish.ui
- modules/launcher/custom-launcher-menu.ui
- modules/launcher/gp-editor.c
- modules/launcher/gp-icon-name-chooser.c
- modules/launcher/gp-icon-name-chooser.ui
+-modules/launcher/custom-launcher-menu.ui
+-modules/launcher/gp-editor.c
+-modules/launcher/gp-icon-name-chooser.c
+-modules/launcher/gp-icon-name-chooser.ui
-modules/launcher/gp-launcher-applet.c
- modules/launcher/gp-launcher-module.c
+-modules/launcher/gp-launcher-module.c
-modules/launcher/gp-launcher-properties.c
- modules/launcher/gp-launcher-utils.c
- modules/launcher/launcher-menu.ui
- modules/launcher/org.gnome.gnome-panel.applet.launcher.gschema.xml
+-modules/launcher/gp-launcher-utils.c
+-modules/launcher/launcher-menu.ui
+-modules/launcher/org.gnome.gnome-panel.applet.launcher.gschema.xml
-modules/menu/gp-bookmarks.c
-modules/menu/gp-lock-logout.c
-modules/menu/gp-menu-bar-applet.c