summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
-rw-r--r--gnome-search-tool.install31
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9b46e05643a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gnome-search-tool-no-nautilus
+ pkgdesc = installs gnome-search-tool to search for files without nautilus or gnome-desktop
+ pkgver = 3.6.0
+ pkgrel = 3
+ url = http://gnome.org
+ install = gnome-search-tool.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ makedepends = yelp-tools
+ depends = nautilus-data
+ depends = libsm
+ provides = gnome-search-tool=3.6.0
+ conflicts = gnome-search-tool
+ options = !emptydirs
+ source = http://download.gnome.org/sources/gnome-search-tool/3.6/gnome-search-tool-3.6.0.tar.xz
+ sha256sums = a33000cd7d033be4ea50422f0f2cca611da5b79bd0f0875017f105a1bc177f42
+
+pkgname = gnome-search-tool-no-nautilus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1976d5fdb65c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 183396 2013-04-21 22:10:19Z heftig $
+# Maintainer: Colin Keenan <colinnkeenan at gmail dot com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+# The difference between this PKGBUILD and the one for gnome-search-tool is "depends..."
+# This will build gnome-search-tool without depending on nautilus.
+# It depends on nautilus-data instead, also available in AUR, and so avoids gnome-desktop
+
+pkgname=gnome-search-tool-no-nautilus
+pkgver=3.6.0
+pkgrel=3
+pkgdesc="installs gnome-search-tool to search for files without nautilus or gnome-desktop"
+arch=(i686 x86_64)
+url="http://gnome.org"
+license=('GPL2')
+depends=('nautilus-data' 'libsm')
+makedepends=('intltool' 'yelp-tools')
+provides=('gnome-search-tool=3.6.0')
+install=gnome-search-tool.install
+conflicts=('gnome-search-tool')
+options=('!emptydirs')
+source=(http://download.gnome.org/sources/gnome-search-tool/${pkgver%.*}/gnome-search-tool-$pkgver.tar.xz)
+sha256sums=('a33000cd7d033be4ea50422f0f2cca611da5b79bd0f0875017f105a1bc177f42')
+
+build() {
+ cd "gnome-search-tool-$pkgver"
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "gnome-search-tool-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-search-tool.install b/gnome-search-tool.install
new file mode 100644
index 000000000000..0faafb370dfe
--- /dev/null
+++ b/gnome-search-tool.install
@@ -0,0 +1,31 @@
+# Some colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+note() {
+ printf "${BLUE}==>${ALL_OFF}${YELLOW} NOTE:${ALL_OFF}${BOLD} ${1}${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="$(tput bold)"
+BLUE="${BOLD}$(tput setaf 4)"
+YELLOW="${BOLD}$(tput setaf 3)"
+
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ note "The command is just 'gnome-search-tool' (without '-no-nautilus')"
+}
+
+pre_upgrade() {
+ (( $(vercmp $2 3.6.0) < 0 )) && gconfpkg --uninstall gnome-search-tool
+ return 0
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}