summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
2 files changed, 25 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6e0d476c805..594360fa1086 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
-pkgbase = gnome-shell-extension-clock-override-git
- pkgdesc = Customize the date and time format displayed in clock in the top bar in GNOME Shell
- pkgver = 5+40+g7dd30bc
+pkgbase = gnome-shell-extension-arch-update-git
+ pkgdesc = Convenient indicator for Arch Linux updates in GNOME Shell
+ pkgver = 33+1+ge9de0e4
pkgrel = 1
- url = https://github.com/stuartlangridge/gnome-shell-clock-override
+ url = https://github.com/RaphaelRochet/arch-update
arch = any
license = GPL
makedepends = git
- makedepends = zip
- depends = gnome-shell>=3.18
- provides = gnome-shell-extension-clock-override
- conflicts = gnome-shell-extension-clock-override
- source = gnome-shell-extension-clock-override-git::git+https://github.com/stuartlangridge/gnome-shell-clock-override.git
- sha512sums = SKIP
+ makedepends = jq
+ depends = gnome-shell
+ provides = gnome-shell-extension-arch-update
+ conflicts = gnome-shell-extension-arch-update
+ source = gnome-shell-extension-arch-update-git::git+https://github.com/RaphaelRochet/arch-update.git
+ sha256sums = SKIP
-pkgname = gnome-shell-extension-clock-override-git
+pkgname = gnome-shell-extension-arch-update-git
diff --git a/PKGBUILD b/PKGBUILD
index 0797f661239f..ec27a147a5e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
# Maintainer: Ranieri Althoff <ranisalt+aur at gmail dot com>
-pkgname=gnome-shell-extension-clock-override-git
-pkgver=5+40+g7dd30bc
+pkgname=gnome-shell-extension-arch-update-git
+pkgver=33+1+ge9de0e4
pkgrel=1
-pkgdesc='Customize the date and time format displayed in clock in the top bar in GNOME Shell'
-url='https://github.com/stuartlangridge/gnome-shell-clock-override'
+pkgdesc='Convenient indicator for Arch Linux updates in GNOME Shell'
+url='https://github.com/RaphaelRochet/arch-update'
license=('GPL')
arch=('any')
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
-makedepends=('git' 'zip')
-depends=('gnome-shell>=3.18')
+depends=(gnome-shell)
+makedepends=('git' 'jq')
source=("${pkgname}::git+${url}.git")
-sha512sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
git describe --long --tags | sed 's/^v//; s/-/+/g'
}
-build() {
- cd "$pkgname"
- make
-}
-
package() {
cd "$pkgname"
- make PREFIX="$pkgdir/usr/share/gnome-shell/extensions/" install
+ uuid=$(jq -r '.uuid' metadata.json)
+ destdir="$pkgdir/usr/share/gnome-shell/extensions/$uuid"
+ install -dm755 "$destdir"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENCE.txt
+ install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" schemas/org.gnome.shell.extensions.arch-update.gschema.xml
+ rm -r LICENCE.txt README.md locale/*/*.po schemas
+ cp -a * "$destdir"
}