summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8b60bf50205..4c3b7d5f5733 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-dash-to-dock
pkgdesc = This extension moves the dash out of the overview transforming it in a dock for an easier launching of applications and a faster switching between windows and desktops.
pkgver = 46
- pkgrel = 3
+ pkgrel = 4
url = https://micheleg.github.io/dash-to-dock/
install = gschemas.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index c0e11bbacfd8..bdeb4d8f285e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _author="micheleg"
pkgname="gnome-shell-extension-${_extname}"
pkgver=46
-pkgrel=3
+pkgrel=4
pkgdesc="This extension moves the dash out of the overview transforming it in a dock for an easier launching of applications and a faster switching between windows and desktops."
arch=("any")
url="https://${_author}.github.io/${_extname}/"
@@ -27,7 +27,10 @@ build() {
package() {
cd "${srcdir}/${_extname}-extensions.gnome.org-v${pkgver}"
- make INSTALLBASE="${pkgdir}/usr/share/gnome-shell/extensions" install
+ make \
+ INSTALLBASE="${pkgdir}/usr/share/gnome-shell/extensions" \
+ VERSION="${pkgver}" \
+ install
_gschema="schemas/org.gnome.shell.extensions.dash-to-dock.gschema.xml"
install -Dm0644 "${_gschema}" "${pkgdir}/usr/share/glib-2.0/${_gschema}"
}