summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD52
-rw-r--r--gschemas.install20
2 files changed, 35 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38a415499da3..47034981a738 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,33 @@
-# Maintainer: Janne Haapsaari <haaja@iki.fi>
-# Contributor: Christopher Krooß <didi2002 at web.de>
-pkgname=gnome-shell-extension-dash-to-dock
-pkgver=v46
-pkgrel=2
-pkgdesc="A gnome-shell extension that transforms the dash into an intellihide dock"
-arch=('any')
-url="https://github.com/micheleg/dash-to-dock"
-license=('GPL')
-depends=('dconf')
-makedepends=('gnome-common' 'intltool')
-provides=('gnome-shell-extension-dash-to-dock')
-conflicts=('gnome-shell-extensions-dash-to-dock-git')
-source=("$pkgname::https://github.com/micheleg/dash-to-dock/archive/extensions.gnome.org-${pkgver}.tar.gz")
-md5sums=('f085cee5b4373029a00d7987081d1d5d')
-install='gschemas.install'
+# Maintainer: Carl George < arch at cgtx dot us >
+# Contributor: Janne Haapsaari < haaja at iki dot fi >
+# Contributor: Christopher Krooß < didi2002 at web dot de >
-_archivename="dash-to-dock-extensions.gnome.org-${pkgver}"
+_extname="dash-to-dock"
+_author="micheleg"
-prepare() {
- cd "$srcdir/$_archivename"
- sed -i 's/INSTALLBASE = ~\/.local\/share\/gnome-shell\/extensions/INSTALLBASE = ${DESTDIR}/'\
- Makefile
-}
+pkgname="gnome-shell-extension-${_extname}"
+pkgver=46
+pkgrel=1
+pkgdesc="This extension moves the dash out of the overview transforming it in a dock for an easier launching of applications and a faster switching between windows and desktops."
+arch=("any")
+url="https://${_author}.github.io/${_extname}/"
+license=("GPL2")
+depends=("dconf")
+makedepends=("gnome-common" "intltool")
+conflicts=("gnome-shell-extensions-dash-to-dock-git")
+install="gschemas.install"
+source=("https://github.com/${_author}/${_extname}/archive/extensions.gnome.org-v${pkgver}.tar.gz")
+noextract=()
+md5sums=("f085cee5b4373029a00d7987081d1d5d")
build() {
- cd "$srcdir/$_archivename"
+ cd "${srcdir}/${_extname}-extensions.gnome.org-v${pkgver}"
make
}
package() {
- cd "$srcdir/$_archivename"
- mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions" "${pkgdir}/usr/share/glib-2.0/schemas/"
- make DESTDIR=${pkgdir}/usr/share/gnome-shell/extensions install
- install -m644 "schemas/org.gnome.shell.extensions.dash-to-dock.gschema.xml" \
- "${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.dash-to-dock.gschema.xml"
+ cd "${srcdir}/${_extname}-extensions.gnome.org-v${pkgver}"
+ make INSTALLBASE="${pkgdir}/usr/share/gnome-shell/extensions" install
+ _gschema="schemas/org.gnome.shell.extensions.dash-to-dock.gschema.xml"
+ install -Dm0644 "${_gschema}" "${pkgdir}/usr/share/glib-2.0/${_gschema}"
}
diff --git a/gschemas.install b/gschemas.install
index 2656464bbbe2..4c2186853aec 100644
--- a/gschemas.install
+++ b/gschemas.install
@@ -1,20 +1,22 @@
+compile_schemas() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+instructions() {
+ echo "Don't forget to restart GNOME Shell ([Alt]+[F2], r) and to enable extension with gnome-tweak-tool."
+}
+
post_install() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ compile_schemas
instructions
}
post_upgrade() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ compile_schemas
instructions
}
post_remove() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ compile_schemas
}
-instructions() {
- /bin/cat << EOF
-Don't forget to restart GNOME Shell ([Alt]+[F2], r) and to enable extension
-with gnome-tweak-tool.
-EOF
-}