summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dee3f4b0946..806a8b8df9f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-dash-to-dock
pkgdesc = Move the dash out of the overview transforming it in a dock
- pkgver = 67
+ pkgver = 67+16+g4fd2776
pkgrel = 1
url = https://micheleg.github.io/dash-to-dock/
arch = any
@@ -9,7 +9,7 @@ pkgbase = gnome-shell-extension-dash-to-dock
makedepends = gettext
makedepends = git
depends = gnome-shell
- source = git+https://github.com/micheleg/dash-to-dock.git#commit=19597e4a40176c2f1a2057984896d8b84f2c40b9
+ source = git+https://github.com/micheleg/dash-to-dock.git#commit=4fd2776643c505859f28907e3f6fa75776ee19b4
sha256sums = SKIP
pkgname = gnome-shell-extension-dash-to-dock
diff --git a/PKGBUILD b/PKGBUILD
index 8f788652f0ba..036435a0ecc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=gnome-shell-extension-dash-to-dock
_pkgname=dash-to-dock
-pkgver=67
+pkgver=67+16+g4fd2776
pkgrel=1
pkgdesc="Move the dash out of the overview transforming it in a dock"
arch=('any')
@@ -14,10 +14,15 @@ url="https://micheleg.github.io/dash-to-dock/"
license=('GPL')
depends=('gnome-shell')
makedepends=('intltool' 'gettext' 'git')
-_commit=19597e4a40176c2f1a2057984896d8b84f2c40b9 # extensions.gnome.org-v67
+_commit=4fd2776643c505859f28907e3f6fa75776ee19b4 # master
source=("git+https://github.com/micheleg/dash-to-dock.git#commit=$_commit")
sha256sums=('SKIP')
+pkgver() {
+ cd "${srcdir}"/${_pkgname}
+ git describe --tags | sed 's/^extensions\.gnome\.org-v//g' | sed 's/-/+/g'
+}
+
build() {
cd "${srcdir}"/${_pkgname}
make