summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce097ebb88a4..18dca85359a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-dash-to-dock
pkgdesc = Move the dash out of the overview transforming it in a dock
pkgver = 67+81+g3e1d49a
- pkgrel = 1
+ pkgrel = 2
url = https://micheleg.github.io/dash-to-dock/
arch = any
license = GPL
@@ -10,7 +10,9 @@ pkgbase = gnome-shell-extension-dash-to-dock
makedepends = git
depends = gnome-shell
source = git+https://github.com/micheleg/dash-to-dock.git#commit=3e1d49af1876e83abd1d16baab24cb263ca53360
+ source = https://patch-diff.githubusercontent.com/raw/micheleg/dash-to-dock/pull/1171.patch
sha256sums = SKIP
+ sha256sums = 13bb4cdb9701d0311c63a96f03decbe2807b88578fe7c61344e1cfb0f28606dc
pkgname = gnome-shell-extension-dash-to-dock
diff --git a/PKGBUILD b/PKGBUILD
index 2f2e04435cd1..a360d682bf68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gnome-shell-extension-dash-to-dock
_pkgname=dash-to-dock
pkgver=67+81+g3e1d49a
-pkgrel=1
+pkgrel=2
pkgdesc="Move the dash out of the overview transforming it in a dock"
arch=('any')
url="https://micheleg.github.io/dash-to-dock/"
@@ -15,14 +15,21 @@ license=('GPL')
depends=('gnome-shell')
makedepends=('intltool' 'gettext' 'git')
_commit=3e1d49af1876e83abd1d16baab24cb263ca53360
-source=("git+https://github.com/micheleg/dash-to-dock.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("git+https://github.com/micheleg/dash-to-dock.git#commit=$_commit"
+ "https://patch-diff.githubusercontent.com/raw/micheleg/dash-to-dock/pull/1171.patch")
+sha256sums=('SKIP'
+ '13bb4cdb9701d0311c63a96f03decbe2807b88578fe7c61344e1cfb0f28606dc')
pkgver() {
cd "${srcdir}"/${_pkgname}
git describe --tags | sed 's/^extensions\.gnome\.org-v//g' | sed 's/-/+/g'
}
+prepare() {
+ cd "${srcdir}"/${_pkgname}
+ patch -Np1 -i "$srcdir/1171.patch"
+}
+
build() {
cd "${srcdir}"/${_pkgname}
make