summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD93
-rw-r--r--gschemas.install20
3 files changed, 21 insertions, 104 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f54ced61ebf1..44f1080b7d1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = gnome-shell-extension-dash-to-dock-git
pkgdesc = move the dash out of the overview transforming it in a dock
- pkgver = 67
+ pkgver = 70.r0.g8dbf454
pkgrel = 1
url = https://micheleg.github.io/dash-to-dock/
- install = gschemas.install
arch = any
license = GPL
- makedepends = intltool
makedepends = git
- depends = dconf
+ makedepends = sassc
depends = gnome-shell
- provides = gnome-shell-extension-dash-to-dock=67
+ provides = gnome-shell-extension-dash-to-dock
conflicts = gnome-shell-extension-dash-to-dock
- source = gnome-shell-extension-dash-to-dock::git+https://github.com/micheleg/dash-to-dock/
- md5sums = SKIP
+ source = git+https://github.com/micheleg/dash-to-dock.git
sha256sums = SKIP
pkgname = gnome-shell-extension-dash-to-dock-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 226145c339d3..17893bdb8b22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,99 +1,40 @@
-# Maintainer: XZS <d dot f dot fischer at web dot de>
+# Maintainer: Amin Vakil <info at aminvakil dot com>
+# Contributor: XZS <d dot f dot fischer at web dot de>
# Contributor: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
# Contributor: Janne Haapsaari <haaja@iki.fi>
# Contributor: Christopher Krooß <didi2002 at web.de>
-# This PKGBUILD is maintained on GitHub <https://github.com/dffischer/gnome-shell-extensions>.
-# You may find it convenient to file issues and pull requests there.
+_srcname=dash-to-dock
pkgname=gnome-shell-extension-dash-to-dock-git
-pkgver=67
+pkgver=70.r0.g8dbf454
pkgrel=1
pkgdesc="move the dash out of the overview transforming it in a dock"
arch=('any')
url="https://micheleg.github.io/dash-to-dock/"
_giturl="git+https://github.com/micheleg/dash-to-dock/"
license=('GPL')
-depends=('dconf')
-makedepends=('intltool')
+depends=('gnome-shell')
+makedepends=('git' 'sassc')
+conflicts=('gnome-shell-extension-dash-to-dock')
+provides=('gnome-shell-extension-dash-to-dock')
+source=("git+https://github.com/micheleg/${_srcname}.git")
+sha256sums=('SKIP')
-makedepends+=('git')
-source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
-for integ in $(get_integlist)
-do
- typeset -n array="${integ}sums"
- array+=('SKIP')
-done
-provides+=("$_gitname=$pkgver")
-conflicts+=("$_gitname")
pkgver() {
- cd ${_gitname:-$pkgname}
+ cd "${_srcname}"
git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
- [ ${PIPESTATUS[0]} -ne 0 ] && \
+ [ ${PIPESTATUS[0]} -eq 0 ] || \
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$_gitname"
+ export SASS=sassc
+ cd "${_srcname}"
make VERSION="$pkgver" _build
}
package() {
- for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$')
- do
- $function
- done
-}
-package_01_locate() {
- msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
- -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
- extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
- destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
-}
-
-package_02_install() {
- msg2 'Installing extension code...'
- find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) \
- -exec install -Dm644 -t "$destdir" '{}' +
-}
-
-package_09_media() {
- cp -r --no-preserve=ownership,mode media "$destdir"
-}
-
-package_10_locale() {
- msg2 'Installing translations...'
- (
- cd locale
- for locale in */
- do
- install -Dm644 -t "$pkgdir/usr/share/locale/$locale/LC_MESSAGES" "$locale/LC_MESSAGES"/*.mo
- done
- )
-}
-if [ -z "$install" ]
-then
- install=gschemas.install
-fi
-
-package_10_schemas() {
- msg2 'Installing schemas...'
- find -name '*.xml' -exec install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" '{}' +
-}
-depends[125]=gnome-shell
-
-package_20_version() {
- local compatibles=($(\
- find -path ./pkg -type d -prune -o \
- -name metadata.json -exec cat '{}' \; | \
- tr -d '\n' | grep -Po '(?<="shell-version": \[)[^\[\]]*(?=\])' | \
- tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
- depends+=("gnome-shell>=3.${compatibles[0]}")
- local max="${compatibles[-1]}"
- if [ "$max" != $(
- gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
- ) ]; then
- depends+=("gnome-shell<3.$((${max%%.*} + 1))")
- fi
- unset depends[125]
+ cd "${_srcname}"
+ make
+ make DESTDIR=${pkgdir} install
}
diff --git a/gschemas.install b/gschemas.install
deleted file mode 100644
index 863897ad5436..000000000000
--- a/gschemas.install
+++ /dev/null
@@ -1,20 +0,0 @@
-post_install() {
- instruct
- echo "and enable the extension with gnome-tweak-tool."
-}
-
-post_upgrade() {
- instruct
- echo "for the changes to have an effect."
-}
-
-post_remove() {
- glib-compile-schemas usr/share/glib-2.0/schemas/
-}
-
-instruct() {
- post_remove
- echo "Don't forget to restart GNOME Shell ([Alt]+[F2], r)"
-}
-
-# vim: ts=2 sw=2 et: