summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 937ba40bd7fd..966c12e40a81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -79,7 +79,8 @@ depends[125]=gnome-shell
package_20_version() {
local compatibles=($(\
find -path ./pkg -type d -prune -o \
- -name metadata.json -exec grep -Pzo '(?s)(?<="shell-version": \[)[^\[\]]*(?=\])' '{}' \; | \
+ -name metadata.json -exec cat '{}' \; | \
+ tr -d '\n' | grep -Po '(?<="shell-version": \[)[^\[\]]*(?=\])' | \
tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
depends+=("gnome-shell>=3.${compatibles[0]}")
local max="${compatibles[-1]}"