summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8ce2b4fe0bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-docker-integration-git
+ pkgdesc = Base Docker&Docker compose integration (start, stop, log, up), hide Docker network (veth*)
+ pkgver = 20160320
+ pkgrel = 1
+ url = https://github.com/Trejjam/Gnome-Docker-integration
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell>=3.18
+ depends = networkmanager
+ provides = docker-integration-applet"
+ source = git://github.com/Trejjam/Gnome-Docker-integration.git
+ sha1sums = SKIP
+
+pkgname = gnome-shell-extension-docker-integration-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..706dcbeac749
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jan Trejbal <jan.trejbal@gmail.com>
+pkgname=gnome-shell-extension-docker-integration-git
+pkgver=20160320
+pkgrel=1
+pkgdesc="Base Docker&Docker compose integration (start, stop, log, up), hide Docker network (veth*)"
+arch=('any')
+url="https://github.com/Trejjam/Gnome-Docker-integration"
+license=('GPL3')
+depends=('gnome-shell>=3.18' 'networkmanager')
+makedepends=('git')
+provides=("docker-integration-applet")
+#install=gschemas.install
+
+_gitroot="git://github.com/Trejjam/Gnome-Docker-integration.git"
+_gitname="gnome-docker-integration"
+
+build() {
+ cd ${srcdir}/
+ msg "Connecting to the GIT server..."
+ if [[ -d ${srcdir}/${_gitname} ]] ; then
+ cd ${_gitname}
+ git pull origin
+ msg "The local files are updated..."
+ else
+ git clone ${_gitroot} ${_gitname}
+ fi
+ msg "GIT checkout done."
+}
+
+package() {
+ cd "$srcdir/gnome-docker-integration"
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/"
+ cp -R "src" "$pkgdir/usr/share/gnome-shell/extensions/docker-integration@jan.trejbal.gmail.com"
+}