summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
-rw-r--r--espresso.install24
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1cea58e5091
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-espresso
+ pkgdesc = Prevent auto suspend and screensaver functions (forked from caffeine)
+ pkgver = 7
+ pkgrel = 1
+ url = https://github.com/coadmunkee/gnome-shell-extension-espresso.git
+ install = espresso.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gnome-shell
+ source = gnome-shell-extension-espresso::git+https://github.com/coadmunkee/gnome-shell-extension-espresso.git#tag=v7
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-espresso
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e679b31223b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Francois Menning <f.menning@pm.me>
+# Contributer: Tony Lambiris <tony@libpcap.net>
+
+pkgname=gnome-shell-extension-espresso
+pkgver=7
+pkgrel=1
+pkgdesc="Prevent auto suspend and screensaver functions (forked from caffeine)"
+arch=('any')
+url="https://github.com/coadmunkee/gnome-shell-extension-espresso.git"
+install=espresso.install
+license=('GPL2')
+depends=('gnome-shell')
+makedepends=('git')
+source=("${pkgname}::git+${url}#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ ./update-locale.sh
+
+ glib-compile-schemas \
+ --targetdir=espresso@coadmunkee.github.com/schemas/ \
+ --strict espresso@coadmunkee.github.com/schemas
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -dm755 "${pkgdir}/usr/share/gnome-shell/extensions"
+ cp -a "espresso@coadmunkee.github.com" "${pkgdir}/usr/share/gnome-shell/extensions"
+}
diff --git a/espresso.install b/espresso.install
new file mode 100644
index 000000000000..19bbbb3c8b72
--- /dev/null
+++ b/espresso.install
@@ -0,0 +1,24 @@
+post_install() {
+ instructions_install
+}
+
+post_upgrade() {
+ instructions_upgrade
+}
+
+instructions_install() {
+ cat <<-EOT
+
+ Restart GNOME Shell ([Alt]+[F2], r).
+ Activate the extension with gnome-tweak-tool.
+
+ EOT
+}
+
+instructions_upgrade() {
+ cat <<-EOT
+
+ Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
+
+ EOT
+}