summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 7 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f84662db154..a1f1e4284a5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = gnome-shell-extension-impatience-git
pkgdesc = speed up gnome-shell animations
- pkgver = 0.4.8.r4.g0f961b8
- pkgrel = 2
+ pkgver = 0.5.1.r0.g8540b71
+ pkgrel = 1
url = https://github.com/timbertson/gnome-shell-impatience
install = gschemas.install
arch = any
license = GPL3
makedepends = git
depends = gnome-shell>=1:45
- depends = gnome-shell<1:46
provides = gnome-shell-extension-impatience
conflicts = gnome-shell-extension-impatience
source = git+https://github.com/timbertson/gnome-shell-impatience
- source = https://patch-diff.githubusercontent.com/raw/timbertson/gnome-shell-impatience/pull/33.diff
sha256sums = SKIP
- sha256sums = f604a5df06d1b215aa26858d268c1618accf70c05dc703296ab067502db6a7d7
pkgname = gnome-shell-extension-impatience-git
diff --git a/PKGBUILD b/PKGBUILD
index 35f41cbcd20c..e2a5451d5d1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,25 @@
# Maintainer: Michael Schubert <mschu.dev at gmail> github.com/mschubert/PKGBUILDs
pkgname=gnome-shell-extension-impatience-git
_pkgname=gnome-shell-impatience
-pkgver=0.4.8.r4.g0f961b8
-pkgrel=2
+pkgver=0.5.1.r0.g8540b71
+pkgrel=1
pkgdesc="speed up gnome-shell animations"
arch=('any')
url="https://github.com/timbertson/gnome-shell-impatience"
license=('GPL3')
-depends=('gnome-shell>=1:45' 'gnome-shell<1:46')
+depends=('gnome-shell>=1:45')
makedepends=('git')
conflicts=('gnome-shell-extension-impatience')
provides=('gnome-shell-extension-impatience')
install=gschemas.install
-source=(git+$url
- https://patch-diff.githubusercontent.com/raw/timbertson/gnome-shell-impatience/pull/33.diff)
-sha256sums=('SKIP'
- 'f604a5df06d1b215aa26858d268c1618accf70c05dc703296ab067502db6a7d7')
+source=(git+$url)
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
git describe --long --tags | sed -r 's/version-//;s/([^-]*-g)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/$_pkgname"
- patch --forward --strip=1 --input="$srcdir"/33.diff
-}
-
package() {
cd "$srcdir/$_pkgname/impatience"