summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD42
-rw-r--r--gschemas.install42
3 files changed, 27 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c565637866e..1f751f148f43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,17 @@
pkgbase = gnome-shell-extension-openweather-git
- pkgdesc = A simple extension for displaying weather informations from several cities in GNOME Shell.
- pkgver = r729.9d0b1b1
+ pkgdesc = Gnome shell extension for displaying weather information
+ pkgver = r1268.9117377
pkgrel = 1
- url = https://github.com/jenslody/gnome-shell-extension-openweather
- install = gschemas.install
+ epoch = 1
+ url = https://github.com/toppk/gnome-shell-extension-openweather
arch = any
license = GPL3
makedepends = git
- makedepends = gnome-common
- makedepends = autoconf
- makedepends = automake
- makedepends = intltool
- depends = glib2
- depends = gettext
- depends = pkg-config
- provides = gnome-shell-extension-weather-neroth-git
+ depends = dconf
+ depends = gnome-shell
provides = gnome-shell-extension-weather-git
- provides = gnome-shell-extension-yawe-git
- conflicts = gnome-shell-extension-weather-neroth-git
conflicts = gnome-shell-extension-weather-git
- conflicts = gnome-shell-extension-yawe-git
- source = gnome-shell-extension-openweather-git::git+https://github.com/jenslody/gnome-shell-extension-openweather#branch=master
+ source = git+https://github.com/toppk/gnome-shell-extension-openweather.git
sha256sums = SKIP
pkgname = gnome-shell-extension-openweather-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9c2db1471f15..adc006cea0cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,35 @@
-# Maintainer: jtts
+# Maintainer: Michael Schubert <mschu.dev at gmail> github.com/mschubert/PKGBUILDs
+# Contributor: Taijian <taijian@posteo.de>
+# Contributor: jtts
# Contributor: Christian METZLER <neroth@xeked.com>
-
pkgname=gnome-shell-extension-openweather-git
-pkgver=r729.9d0b1b1
+_pkgbase=gnome-shell-extension-openweather
+pkgver=r1268.9117377
pkgrel=1
-pkgdesc="A simple extension for displaying weather informations from several cities in GNOME Shell."
+epoch=1
+pkgdesc="Gnome shell extension for displaying weather information"
arch=(any)
-url="https://github.com/jenslody/gnome-shell-extension-openweather"
+url="https://github.com/toppk/gnome-shell-extension-openweather"
license=(GPL3)
-depends=(glib2 gettext pkg-config)
-makedepends=(git gnome-common autoconf automake intltool)
-provides=(gnome-shell-extension-weather-neroth-git
- gnome-shell-extension-weather-git
- gnome-shell-extension-yawe-git)
-conflicts=(gnome-shell-extension-weather-neroth-git
- gnome-shell-extension-weather-git
- gnome-shell-extension-yawe-git)
-install='gschemas.install'
-source=("$pkgname"::"git+https://github.com/jenslody/gnome-shell-extension-openweather#branch=master")
+depends=('dconf' 'gnome-shell')
+makedepends=('git')
+provides=(gnome-shell-extension-weather-git)
+conflicts=(gnome-shell-extension-weather-git)
+source=(git+$url.git)
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$_pkgbase"
+ #git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {
- cd "$srcdir/$pkgname"
- ./autogen.sh --prefix=/usr
- make
+ cd "$srcdir/$_pkgbase"
+ make mergepo
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgbase"
make DESTDIR=$pkgdir install
-} \ No newline at end of file
+}
diff --git a/gschemas.install b/gschemas.install
deleted file mode 100644
index 2fbf27d8628d..000000000000
--- a/gschemas.install
+++ /dev/null
@@ -1,42 +0,0 @@
-post_install() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_install
-}
-
-post_upgrade() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_upgrade
-}
-
-post_remove() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
-}
-
-instructions_install() {
- /bin/cat << EOF
-
-Restart GNOME Shell ([Alt]+[F2], r).
-Active the extension with gnome-tweak-tool.
-Configure with the Weather Settings button.
-For more informations, see https://github.com/jenslody/gnome-shell-extension-openweather
-
-EOF
-}
-
-instructions_upgrade() {
- /bin/cat << EOF
-
-Just restart GNOME Shell ([Alt]+[F2], r).
-What new ?
- * Currently, the weather data is fetched from OpenWeatherMap (including
- forecasts for up to ten days) or forecast.io (including forecasts for
- up to eight days).
- * Note: since version 29 this extensions uses coordinates to store the
- locations and makes the names editable to support multiple
- weather-providers! If you update from versions prior to 29 to 29 or greater
- (with forecast.io - support) you have to recreate your locations.
-
-For more informations, see https://github.com/jenslody/gnome-shell-extension-openweather
-
-EOF
-}