summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD28
-rw-r--r--gnome-shell-extension.install4
3 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 448eb4ab83e4..3f191d68b55c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-proxy-switcher-git
pkgdesc = Extension for GNOME shell to switch between the system proxy settings.
- pkgver = 1.2.r6.g549d1aa
+ pkgver = 2.0.r0.gdec14a0
pkgrel = 1
url = https://github.com/tomflannaghan/proxy-switcher
install = gnome-shell-extension.install
@@ -8,11 +8,10 @@ pkgbase = gnome-shell-extension-proxy-switcher-git
license = GPL2
makedepends = git
makedepends = python
- depends = gnome-shell>=3.18
+ depends = gnome-shell>=43.0
provides = gnome-shell-extension-proxy-switcher
conflicts = gnome-shell-extension-proxy-switcher
source = git+https://github.com/tomflannaghan/proxy-switcher.git
sha256sums = SKIP
pkgname = gnome-shell-extension-proxy-switcher-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 5902a41a71e5..1bd090ff57c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
-# $Id$
# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
pkgname=gnome-shell-extension-proxy-switcher-git
-pkgver=1.2.r6.g549d1aa
+pkgver=2.0.r0.gdec14a0
pkgrel=1
pkgdesc='Extension for GNOME shell to switch between the system proxy settings.'
arch=(any)
@@ -10,7 +9,7 @@ _githubname=proxy-switcher
_githubowner=tomflannaghan
url="https://github.com/${_githubowner}/${_githubname}"
license=(GPL2)
-depends=('gnome-shell>=3.18')
+depends=('gnome-shell>=43.0')
makedepends=('git' 'python')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -19,23 +18,24 @@ source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_githubname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_githubname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${_githubname}"
- sed -i 's|INSTALL_LOC=.*|INSTALL_LOC=$(DESTDIR)/usr/share/gnome-shell/extensions|g' \
- Makefile
+ cd "${srcdir}/${_githubname}"
+ sed -i 's|INSTALL_LOC=.*|INSTALL_LOC=$(DESTDIR)/usr/share/gnome-shell/extensions|g' \
+ Makefile
}
+
build() {
- cd "${srcdir}/${_githubname}"
- make build
+ cd "${_githubname}"
+ make build
}
package() {
- cd "${srcdir}/${_githubname}"
- install -d "$pkgdir/usr/share/gnome-shell/extensions"
- make DESTDIR="$pkgdir" install
+ cd "${_githubname}"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions"
+ make DESTDIR="${pkgdir}" install
}
-# vim:set ts=2 sw=2 et:
+# vim:set ts=4 sw=4 et:
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
index 484bc1b03f77..0bdba153ae31 100644
--- a/gnome-shell-extension.install
+++ b/gnome-shell-extension.install
@@ -1,7 +1,7 @@
post_install() {
echo "==> ****************************************************"
- echo "==> Don't forget to Restart GNOME Shell ([Alt]+[F2], r)."
- echo "==> ****************************************************"
+ echo "==> Don't forget to Restart GNOME Shell ([Alt]+[F2], r)."
+ echo "==> ****************************************************"
}
post_upgrade() {