summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD27
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 448eb4ab83e4..c96b03e81bc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-proxy-switcher-git
pkgdesc = Extension for GNOME shell to switch between the system proxy settings.
pkgver = 1.2.r6.g549d1aa
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tomflannaghan/proxy-switcher
install = gnome-shell-extension.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 5902a41a71e5..802226e9dd89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-# $Id$
-# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
+# Maintainer: M A < morealaz at gmail dot com >
pkgname=gnome-shell-extension-proxy-switcher-git
pkgver=1.2.r6.g549d1aa
-pkgrel=1
+pkgrel=2
pkgdesc='Extension for GNOME shell to switch between the system proxy settings.'
arch=(any)
_githubname=proxy-switcher
@@ -19,23 +18,23 @@ source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_githubname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${srcdir}/${_githubname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${_githubname}"
- sed -i 's|INSTALL_LOC=.*|INSTALL_LOC=$(DESTDIR)/usr/share/gnome-shell/extensions|g' \
- Makefile
+ cd "${srcdir}/${_githubname}"
+ sed -i 's|INSTALL_LOC=.*|INSTALL_LOC=$(DESTDIR)/usr/share/gnome-shell/extensions|g' \
+ Makefile
}
build() {
- cd "${srcdir}/${_githubname}"
- make build
+ cd "${srcdir}/${_githubname}"
+ make build
}
package() {
- cd "${srcdir}/${_githubname}"
- install -d "$pkgdir/usr/share/gnome-shell/extensions"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${_githubname}"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions"
+ make DESTDIR="$pkgdir" install
}
-# vim:set ts=2 sw=2 et:
+# vim:set ts=4 sw=4 et: