summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc3da99b67d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-remmina-search-provider
+ pkgdesc = Remmina Search Provider
+ pkgver = r48.360ea9a
+ pkgrel = 1
+ url = https://github.com/alexmurray/remmina-search-provider
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gnome-shell
+ depends = remmina
+ source = git+https://github.com/alexmurray/remmina-search-provider
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-remmina-search-provider
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b40657dca496
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Peter Reschenhofer <peter.reschenhofer@gmail.com>
+pkgname=gnome-shell-extension-remmina-search-provider
+_pkgname=${pkgname%-git}
+
+pkgver=r48.360ea9a
+pkgrel=1
+pkgdesc="Remmina Search Provider"
+arch=('any')
+url="https://github.com/alexmurray/remmina-search-provider"
+license=('GPL')
+depends=('gnome-shell' 'remmina')
+makedepends=('git')
+source=("git+https://github.com/alexmurray/remmina-search-provider")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/remmina-search-provider"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions"
+ mv remmina-search-provider "$pkgdir/usr/share/gnome-shell/extensions/remmina-search-provider@alexmurray.github.com"
+}