summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--0001-fix-compatibility-with-gnome40.patch54
-rw-r--r--0002-Declare-compatibility-with-GNOME-Shell-41.patch31
-rw-r--r--0003-Declare-GNOME-Shell-42-compatibility.patch26
-rw-r--r--PKGBUILD20
5 files changed, 135 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64daecd1de83..0e8e5ef24297 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = gnome-shell-extension-topicons-plus
pkgdesc = Moves legacy tray icons to the top panel
pkgver = 27
- pkgrel = 2
+ pkgrel = 5
url = https://github.com/phocean/TopIcons-plus
arch = any
license = GPL2
depends = gnome-shell
source = gnome-shell-extension-topicons-plus-27.tar.gz::https://github.com/phocean/TopIcons-plus/archive/27.tar.gz
+ source = 0001-fix-compatibility-with-gnome40.patch
+ source = 0002-Declare-compatibility-with-GNOME-Shell-41.patch
+ source = 0003-Declare-GNOME-Shell-42-compatibility.patch
sha256sums = 51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8
+ sha256sums = e3ed60fd7d9830ac53cf34adee24c26fab1092660705d079bbb15e15a82b6381
+ sha256sums = e4106d408a90af0d7c633cce394c276d35e2a69111758ad3229b42f8e19e53b8
+ sha256sums = 65b6970d4aadfcfce256e4830fde711a5aad3fd328ce9cb42e5b7457047c866f
pkgname = gnome-shell-extension-topicons-plus
-
diff --git a/0001-fix-compatibility-with-gnome40.patch b/0001-fix-compatibility-with-gnome40.patch
new file mode 100644
index 000000000000..5472291f036c
--- /dev/null
+++ b/0001-fix-compatibility-with-gnome40.patch
@@ -0,0 +1,54 @@
+From aa6d016f42dd4ac80275ba7e72ac669f9c8d82e6 Mon Sep 17 00:00:00 2001
+From: Tiramisu Mokka <kofemann@gmail.com>
+Date: Fri, 19 Mar 2021 19:00:32 +0100
+Subject: [PATCH 1/3] fix compatibility with gnome40
+
+---
+ metadata.json | 5 ++---
+ prefs.js | 6 ++----
+ 2 files changed, 4 insertions(+), 7 deletions(-)
+
+diff --git a/metadata.json b/metadata.json
+index e4c9691..8a07918 100644
+--- a/metadata.json
++++ b/metadata.json
+@@ -3,11 +3,10 @@
+ "name": "TopIcons Plus",
+ "gettext-domain": "TopIcons-Plus",
+ "shell-version": [
+- "3.34",
+- "3.36"
++ "40"
+ ],
+ "settings-schema": "org.gnome.shell.extensions.topicons",
+ "url": "https://github.com/phocean/TopIcons-plus",
+ "uuid": "TopIcons@phocean.net",
+- "version": 27
++ "version": 28
+ }
+diff --git a/prefs.js b/prefs.js
+index bd372d2..f6b1277 100644
+--- a/prefs.js
++++ b/prefs.js
+@@ -12,7 +12,7 @@ const Gettext = imports.gettext.domain(Me.metadata['gettext-domain']);
+ const _ = Gettext.gettext;
+
+ function init() {
+- Convenience.initTranslations();
++ ExtensionUtils.initTranslations();
+ }
+
+ const TopIconsPlusSettings = new GObject.Class({
+@@ -180,8 +180,6 @@ const TopIconsPlusSettings = new GObject.Class({
+ });
+
+ function buildPrefsWidget() {
+- let widget = new TopIconsPlusSettings();
+- widget.show_all();
++ return new TopIconsPlusSettings();
+
+- return widget;
+ }
+--
+2.35.3
+
diff --git a/0002-Declare-compatibility-with-GNOME-Shell-41.patch b/0002-Declare-compatibility-with-GNOME-Shell-41.patch
new file mode 100644
index 000000000000..ab65238e1242
--- /dev/null
+++ b/0002-Declare-compatibility-with-GNOME-Shell-41.patch
@@ -0,0 +1,31 @@
+From 5e9e011be38645452e74b5b82741d426d2019657 Mon Sep 17 00:00:00 2001
+From: Simon McVittie <smcv@debian.org>
+Date: Sun, 17 Oct 2021 11:57:39 +0100
+Subject: [PATCH 2/3] Declare compatibility with GNOME Shell 41
+
+From some brief testing, it seems to be compatible without further
+changes.
+
+Bug-Debian: https://bugs.debian.org/996073
+Signed-off-by: Simon McVittie <smcv@debian.org>
+---
+ metadata.json | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/metadata.json b/metadata.json
+index 8a07918..9da5655 100644
+--- a/metadata.json
++++ b/metadata.json
+@@ -3,7 +3,8 @@
+ "name": "TopIcons Plus",
+ "gettext-domain": "TopIcons-Plus",
+ "shell-version": [
+- "40"
++ "40",
++ "41"
+ ],
+ "settings-schema": "org.gnome.shell.extensions.topicons",
+ "url": "https://github.com/phocean/TopIcons-plus",
+--
+2.35.3
+
diff --git a/0003-Declare-GNOME-Shell-42-compatibility.patch b/0003-Declare-GNOME-Shell-42-compatibility.patch
new file mode 100644
index 000000000000..f6c7249d821c
--- /dev/null
+++ b/0003-Declare-GNOME-Shell-42-compatibility.patch
@@ -0,0 +1,26 @@
+From f86add72c1c7d8036a1229f3bdf116639da81bae Mon Sep 17 00:00:00 2001
+From: "j.r" <j.r@jugendhacker.de>
+Date: Sun, 17 Apr 2022 11:47:20 +0200
+Subject: [PATCH 3/3] Declare GNOME Shell 42 compatibility
+
+---
+ metadata.json | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/metadata.json b/metadata.json
+index 9da5655..1fbd6d4 100644
+--- a/metadata.json
++++ b/metadata.json
+@@ -4,7 +4,8 @@
+ "gettext-domain": "TopIcons-Plus",
+ "shell-version": [
+ "40",
+- "41"
++ "41",
++ "42"
+ ],
+ "settings-schema": "org.gnome.shell.extensions.topicons",
+ "url": "https://github.com/phocean/TopIcons-plus",
+--
+2.35.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 16596cb3e769..12416888ba37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,28 @@
pkgname=gnome-shell-extension-topicons-plus
pkgver=27
-pkgrel=2
+pkgrel=5
pkgdesc="Moves legacy tray icons to the top panel"
arch=('any')
url="https://github.com/phocean/TopIcons-plus"
license=('GPL2')
depends=('gnome-shell')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phocean/TopIcons-plus/archive/${pkgver}.tar.gz")
-sha256sums=('51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phocean/TopIcons-plus/archive/${pkgver}.tar.gz"
+ "0001-fix-compatibility-with-gnome40.patch"
+ "0002-Declare-compatibility-with-GNOME-Shell-41.patch"
+ "0003-Declare-GNOME-Shell-42-compatibility.patch")
+sha256sums=('51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8'
+ 'e3ed60fd7d9830ac53cf34adee24c26fab1092660705d079bbb15e15a82b6381'
+ 'e4106d408a90af0d7c633cce394c276d35e2a69111758ad3229b42f8e19e53b8'
+ '65b6970d4aadfcfce256e4830fde711a5aad3fd328ce9cb42e5b7457047c866f')
+
+prepare() {
+ cd "${srcdir}/TopIcons-plus-${pkgver}"
+
+ patch -p1 -i ${srcdir}/0001-fix-compatibility-with-gnome40.patch
+ patch -p1 -i ${srcdir}/0002-Declare-compatibility-with-GNOME-Shell-41.patch
+ patch -p1 -i ${srcdir}/0003-Declare-GNOME-Shell-42-compatibility.patch
+}
build(){
cd "${srcdir}/TopIcons-plus-${pkgver}"