summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 796e164b1c3a..de0ebb3e089f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,16 +13,19 @@ depends=('gnome-shell')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phocean/TopIcons-plus/archive/${pkgver}.tar.gz")
sha256sums=('51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8')
+build(){
+ cd "${srcdir}/TopIcons-plus-${pkgver}"
+
+ make build
+}
+
package() {
- _uuid='TopIcons@phocean.net'
-
cd "${srcdir}/TopIcons-plus-${pkgver}"
- install -d "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ make install INSTALL_PATH=${pkgdir}/usr/share/gnome-shell/extensions
+
install -Dm644 "schemas/org.gnome.shell.extensions.topicons.gschema.xml" \
-t "${pkgdir}/usr/share/glib-2.0/schemas/"
-
- cp -af * "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
}
# vim:set ts=2 sw=2 et: