summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ccd8ee346ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-topicons-redux-git
+ pkgdesc = TopIcons Redux is a fork of TopIcons Plus
+ pkgver = 6+0+g5008e48
+ pkgrel = 1
+ url = https://gitlab.com/pop-planet/TopIcons-Redux
+ arch = any
+ groups = gnome-shell-extensions
+ license = GPL
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-topicons-redux
+ conflicts = gnome-shell-extension-topicons-redux
+ source = git+https://gitlab.com/pop-planet/TopIcons-Redux.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-topicons-redux-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b551d33600a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jianfeng Zhang <swordfeng123@gmail.com>
+
+pkgname=gnome-shell-extension-topicons-redux-git
+_projectName=TopIcons-Redux
+pkgver=6+0+g5008e48
+pkgrel=1
+pkgdesc='TopIcons Redux is a fork of TopIcons Plus'
+arch=('any')
+url="https://gitlab.com/pop-planet/${_projectName}"
+license=('GPL')
+depends=('gnome-shell')
+makedepends=('git')
+provides=('gnome-shell-extension-topicons-redux')
+conflicts=('gnome-shell-extension-topicons-redux')
+groups=('gnome-shell-extensions')
+source=("git+https://gitlab.com/pop-planet/${_projectName}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_projectName}"
+ git describe --tags --long | sed 's/^v//; s/-/+/g'
+}
+
+build() {
+ cd "${_projectName}"
+ make build
+}
+
+package() {
+ cd "${_projectName}"
+ local uuid=$(grep -Po '(?<="uuid": ")[^"]*' _build/metadata.json)
+ local destdir="$pkgdir/usr/share/gnome-shell/extensions/$uuid"
+ install -dm755 "$destdir"
+ cp -r _build/* "$destdir"
+}