summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d31cbd5eec7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-windowisready_remover-git
+ pkgdesc = GNOME shell extension that removes the annoying "Windows is Ready" notification.
+ pkgver = r35.f8bfd6f
+ pkgrel = 1
+ url = https://github.com/nunofarruca/WindowIsReady_Remover
+ arch = any
+ license = Apache-2.0
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-windowisready_remover
+ conflicts = gnome-shell-extension-windowisready_remover
+ source = gnome-shell-extension-windowisready_remover-git::git+https://github.com/nunofarruca/WindowIsReady_Remover
+ b2sums = SKIP
+
+pkgname = gnome-shell-extension-windowisready_remover-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96aed7d1ac34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ArcanusNEO <admin@transcliff.top>
+_pkgname=gnome-shell-extension-windowisready_remover
+pkgname=$_pkgname-git
+pkgver=r35.f8bfd6f
+pkgrel=1
+pkgdesc='GNOME shell extension that removes the annoying "Windows is Ready" notification.'
+arch=("any")
+url="https://github.com/nunofarruca/WindowIsReady_Remover"
+license=("Apache-2.0")
+depends=("gnome-shell")
+makedepends=("git")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+$url")
+b2sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ local _uuid="windowIsReady_Remover@nunofarruca@gmail.com"
+ find ${_uuid} -regextype posix-egrep -regex ".*\.(js|json)$" -exec install -Dm644 {} ${pkgdir}/usr/share/gnome-shell/extensions/{} \;
+}