summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--gnome-shell-extension-workspace-grid-git.install11
3 files changed, 9 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f479092dd98..b3ced4c279ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = gnome-shell-extension-workspace-grid-git
pkgdesc = Allows to configure your workspaces in a grid
- pkgver = 1.4.0.3
+ pkgver = 1.5.17
pkgrel = 1
- url = https://github.com/zakkak/workspace-grid-gnome-shell-extension
- install = gnome-shell-extension-workspace-grid-git.install
+ url = https://github.com/zakkak/workspace-grid
arch = any
license = GPL3
makedepends = git
depends = gnome-shell
replaces = gnome-shell-extension-workspace-grid
- source = gnome-shell-extension-workspace-grid-git::git+https://github.com/zakkak/workspace-grid-gnome-shell-extension.git
+ source = gnome-shell-extension-workspace-grid-git::git+https://github.com/zakkak/workspace-grid#branch=3.30
sha256sums = SKIP
pkgname = gnome-shell-extension-workspace-grid-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c5f79f823ac..db74e86f18a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,21 @@
# Contributor: Foivos S. Zakkak <foivos at zakkak dot net>
pkgname=gnome-shell-extension-workspace-grid-git
-pkgver=1.4.0.3
+pkgver=1.5.17
pkgrel=1
pkgdesc="Allows to configure your workspaces in a grid"
arch=(any)
-url="https://github.com/zakkak/workspace-grid-gnome-shell-extension"
+url="https://github.com/zakkak/workspace-grid"
license=('GPL3')
depends=('gnome-shell')
replaces=('gnome-shell-extension-workspace-grid')
makedepends=('git')
-install=gnome-shell-extension-workspace-grid-git.install
-source=("$pkgname::git+https://github.com/zakkak/workspace-grid-gnome-shell-extension.git")
+source=("$pkgname::git+https://github.com/zakkak/workspace-grid#branch=3.30")
sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
- git describe --long | sed -r 's/^v//;s/([^-]*)-g.*$/\1/;s/-/./g'
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*)-g.*$/\1/;s/-/./g'
}
package() {
@@ -28,6 +27,8 @@ package() {
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
install -m644 "${_uuid}/extension.js" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
+ install -m644 "${_uuid}/utils.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/utils.js"
install -m644 "${_uuid}/convenience.js" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/convenience.js"
install -m644 "${_uuid}/prefs.js" \
diff --git a/gnome-shell-extension-workspace-grid-git.install b/gnome-shell-extension-workspace-grid-git.install
deleted file mode 100644
index 8cd7bfd8ba3b..000000000000
--- a/gnome-shell-extension-workspace-grid-git.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- glib-compile-schemas usr/share/glib-2.0/schemas
-}
-
-post_upgrade() {
- glib-compile-schemas usr/share/glib-2.0/schemas
-}
-
-post_remove() {
- glib-compile-schemas usr/share/glib-2.0/schemas
-}