summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--gnome-shell-extension-zorin-taskbar.install7
3 files changed, 29 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c1d11962441..97306c21ff8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
-# Generated by mksrcinfo v8
-# Wed Aug 30 12:41:39 UTC 2017
pkgbase = gnome-shell-extension-zorin-taskbar
pkgdesc = Various settings and changes for the panel in Zorin Desktop.
- pkgver = 1.3_all
+ pkgver = 40.20
pkgrel = 1
- url = http://zorinos.com/
+ url = https://github.com/ZorinOS/zorin-taskbar
install = gnome-shell-extension-zorin-taskbar.install
- arch = i686
- arch = x86_64
- license = GPL-2+
+ arch = any
+ license = GPL-2.0
depends = gnome-shell
options = !emptydirs
options = !strip
- source = http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-taskbar/gnome-shell-extension-zorin-taskbar_1.3_all.deb
- md5sums = fabaa7766a509fd9f91896e601906e5c
+ source = zorin-taskbar-40.20.tar.gz::https://github.com/ZorinOS/zorin-taskbar/archive/refs/tags/40.20.tar.gz
+ md5sums = 6c7d47fc8021dd2e5fca1871595ee2a4
+ sha256sums = b88c44dfc50fed9f20da2adff52245c41c6a5df7d3ddd6fba2c2f5a8077472af
pkgname = gnome-shell-extension-zorin-taskbar
-
diff --git a/PKGBUILD b/PKGBUILD
index e9740d053db9..f444aec0b2e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
+#Maintainer: GT610 <myddz1005@163.com>
+
pkgname=gnome-shell-extension-zorin-taskbar
-pkgver=1.3_all
+_name=zorin-taskbar
+pkgver=40.20
pkgrel=1
pkgdesc="Various settings and changes for the panel in Zorin Desktop."
-arch=('i686' 'x86_64')
-url="http://zorinos.com/"
-license=('GPL-2+')
+arch=('any')
+url="https://github.com/ZorinOS/zorin-taskbar"
+license=('GPL-2.0')
depends=('gnome-shell')
options=('!emptydirs' '!strip')
install=${pkgname}.install
-source=('http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-taskbar/gnome-shell-extension-zorin-taskbar_1.3_all.deb')
-md5sums=('fabaa7766a509fd9f91896e601906e5c')
+source=(${_name}-${pkgver}.tar.gz::https://github.com/ZorinOS/${_name}/archive/refs/tags/${pkgver}.tar.gz)
+md5sums=('6c7d47fc8021dd2e5fca1871595ee2a4')
+sha256sums=('b88c44dfc50fed9f20da2adff52245c41c6a5df7d3ddd6fba2c2f5a8077472af')
+
+build() {
+ cd "${srcdir}"/${_name}-${pkgver}
+ make
+}
package() {
- msg2 "Extracting the data.tar.xz..."
- bsdtar -xf data.tar.xz -C "$pkgdir/"
+ cd "${srcdir}"/${_name}-${pkgver}
+ make DESTDIR="${pkgdir}" VERSION="${pkgver}" install
}
-
diff --git a/gnome-shell-extension-zorin-taskbar.install b/gnome-shell-extension-zorin-taskbar.install
index 13eccced9b4f..d02b6473236c 100644
--- a/gnome-shell-extension-zorin-taskbar.install
+++ b/gnome-shell-extension-zorin-taskbar.install
@@ -1,9 +1,12 @@
post_install() {
glib-compile-schemas usr/share/glib-2.0/schemas
echo "==============================================================="
+ echo "The current version of this extension only works with \033[41;30;2mGNOME 40 or lower\033[0m\!"
+ echo "If you're using the latest GNOME, it can't be enabled."
+ echo "==============================================================="
echo "To use the extension:"
- echo " * Restart GNOME Shell ([Alt]+[F2], r)"
- echo " * Activate it (eg using gnome-tweak-tool)"
+ echo " * Restart GNOME Shell ([Alt]+[F2], r) or reboot your computer"
+ echo " * Activate it in GNOME Extensions"
echo "==============================================================="
}